[haiku-depot-web] Re: API getPkg()

  • From: Andrew Lindesay <apl@xxxxxxxxxxxxxx>
  • To: haiku-depot-web@xxxxxxxxxxxxx
  • Date: Tue, 08 Apr 2014 19:45:00 +1200

Hi Stephan;

I think the API should be called along the lines of "getPkgInfo". And
besides the (average) rating, I also need the categories of each package.
But why not make the API such that the client says which information to
include in the reply dynamically? Is this harder to do on the Java side?
It may be one of those times where declaring and annotating Java types
to be automatically transformed into JSON is getting in the way.

It would not be hard to do, but I don't see how declaring the return data-structure for the resultant payload could constrain what I am doing in any way *except* that transmission of bulk feeds of data are not going to make any sense via an RPC mechanism because that's not generally how an RPC mechanism works.

If you had envisioned a data feed of packages' data rather than an RPC style API then let's try that. If you were to supply a URL like this...


...that squirted out a feed (maybe RSS or ATOM), would that be more amenable to what you are trying to work with?


Andrew Lindesay

Other related posts: