[gmpi] Re: low level API

  • From: Tim Hockin <thockin@xxxxxxxxxx>
  • To: gmpi@xxxxxxxxxxxxx
  • Date: Fri, 4 Feb 2005 08:05:17 -0800

OK< I am trying not to get into code conventions yet, but I have to make a
personal argument here:

On Fri, Feb 04, 2005 at 10:11:18AM -0500, gogins@xxxxxxxxxxxx wrote:
>   uint32_t (*QueryInterface)(void *thisPointer, REFID interfaceIdentifier,
> void **pointerToReceivePointerToInterface);

why on earth are names this long a good idea?  I know *I* can't remember
them.

thisPointer => this or this_p
interfaceIdentifier => intf_id or interface_id or even just id
pointerToReceivePointerToInterface => interface

Then code can fit on one line.  I detest the notion that adding "Pointer
To Receive Pointer To" is added to a variable name.  It's longhand
hungarian silliness.  The fact that it is a void ** says the exact same
thing.

----------------------------------------------------------------------
Generalized Music Plugin Interface (GMPI) public discussion list
Participation in this list is contingent upon your abiding by the
following rules:  Please stay on topic.  You are responsible for your own
words.  Please respect your fellow subscribers.  Please do not
redistribute anyone else's words without their permission.

Archive: //www.freelists.org/archives/gmpi
Email gmpi-request@xxxxxxxxxxxxx w/ subject "unsubscribe" to unsubscribe

Other related posts: