[glideplan_swproj] Re: CoreInterface name

  • From: Cestmir Houska <czestmyr@xxxxxxxxx>
  • To: glideplan_swproj@xxxxxxxxxxxxx
  • Date: Wed, 23 Nov 2011 20:56:02 +0100

On Wed, Nov 23, 2011 at 8:50 PM, Kuba Marek <blue.cube@xxxxxxxxx> wrote:

> > Hi all!
> >
> > I wonder if we should not change the name of the core interface class,
> > because it is not an interface in the object-oriented sense of the
> > word (whereas on the other hand the PluginInterface class is really an
> > interface). I propose CoreAPI. Yeah, there's interface in the acronym
> > as well, but it's not ambiguous anymore.
> >
> > Cestmir
> It's not an api either, only part of an api. Coreinterface was IMHO more
> fitting name ... not that it matters (as long as the name doesn't
> change while we're using it).

Yeah, I agree that it probably shouldn't change while in use. That's why I
brought up the issue here. It IS an interface between plugins and the core,
but it is NOT an interface class. Maybe we could change the naming
conventions for the interface classes. Once I saw in a different project
that they were appending the names of all interface classes with capital
"I". So PluginInterface would become IPlugin. And CoreInterface would
remain CoreInterface and it would immediately be apparent that the class is
not an interface class.


Other related posts: