[haiku-development] Re: RFC: password roster API

On 2011-01-25 at 19:49:30 [+0100], Axel Dörfler <axeld@xxxxxxxxxxxxxxxx> 
wrote:
> Ingo Weinhold <ingo_weinhold@xxxxxx> wrote:
> > On 2011-01-24 at 23:46:51 [+0100], Axel Dörfler <axeld@xxxxxxxxxxxxxxxx>
> > > wrote:
> > > --------------8<--------------
> > > class BPasswordRoster {
> > I don't have the time for a closer look ATM, so just a quick comment
> > on the
> > name. I think the "roster" metaphor doesn't fit that well in this
> > case.
> > "Manager" would be more suitable IMO.
> 
> According to http://www.merriam-webster.com/dictionary/roster the 2nd
> definition is an "itemized list", so I would think it still fits well
> enough.

From how I've seen the word used (and that's also the impression I get from 
the referred-to English-language learners definition) such a list seems to 
be (semi-)public. That doesn't feel right for a private password/key store, 
which, if I understand it correctly, this is what the class is actually 
about.

> Before introducing a public *Manager class, I would prefer to call it
> something like BKeychain.

I guess more correctly: BKeyChain. But, since it contains key rings, 
BKeyStore or BKeySafe seem more fitting.

CU, Ingo

Other related posts: