[THIN] KB: CTX104631 - How to Repair Clipboard Functionality

  • From: "Jim Kenzig http://thethin.net" <jimkenz@xxxxxxxxxxxxxx>
  • To: thin@xxxxxxxxxxxxx
  • Date: Wed, 17 Nov 2004 04:42:19 -0800 (PST)

CTX104631 - How to Repair Clipboard Functionality 

This document was published at: 
http://support.citrix.com/kb/entry.jspa?externalID=CTX104631 


Document ID: CTX104631, Created on: Sep 17, 2004, Updated: Nov 14, 2004 
Products: Citrix MetaFrame 1.8 for Microsoft NT 4.0 Server Terminal Server 
Edition, Citrix MetaFrame 1.8 for Microsoft Windows 2000, Citrix MetaFrame 
Presentation Server 3.0 for Microsoft Windows 2000, Citrix MetaFrame 
Presentation Server 3.0 for Microsoft Windows 2003, Citrix MetaFrame XP 1.0 for 
Microsoft NT 4.0 Server Terminal Server Edition, Citrix MetaFrame XP 1.0 for 
Microsoft Windows 2000, Citrix MetaFrame XP 1.0 for Microsoft Windows 2003, ICA 
Win32 Program Neighborhood Agent, ICA Win32 Program Neighborhood Client, ICA 
Win32 Web Client 

Attachment: RepairCBDChain.zip (12.1 K) 
 
Symptoms

Users sometimes experience a malfunctioning clipboard chain (when they cannot 
copy/paste anymore between a local application and a session or between 
different applications in a session).

Cause

This occurs when a third-party program incorrectly inserts itself in the 
Windows clipboard chain on a local workstation or within a session.

Resolution

Run the RepairCBDChain utility on your workstation and/or inside the session 
desktop. This temporarily restores clipboard functionality.

The utility displays a message stating that clipboard functionality is repaired 
or a diagnostic message appears.

Status

The RepairCBDChain utility is currently at Version 1.1. Additional 
functionality will be added in the future including the ability to detect which 
application is causing the clipboard chain to malfunction.

Additional Information

CTX086028 ? Troubleshooting Client Clipboard Issues


Other related posts:

  • » [THIN] KB: CTX104631 - How to Repair Clipboard Functionality