[haiku-commits] Re: r41122 - in haiku/trunk/src/apps/mediaplayer: . playlist

  • From: Jonas Sundström <jonas@xxxxxxxxxxx>
  • To: haiku-commits@xxxxxxxxxxxxx <haiku-commits@xxxxxxxxxxxxx>
  • Date: Sun, 27 Mar 2011 15:39:19 +0200

On 2011-03-27 at 09:55:29 [+0200], Stephan Aßmus <superstippi@xxxxxx> wrote:
> On 27.03.2011 00:21, jonas@xxxxxxxxxxx wrote:
> > Author: kirilla
> > Date: 2011-03-27 00:21:13 +0100 (Sun, 27 Mar 2011)
> > New Revision: 41122
> > Changeset: https://dev.haiku-os.org/changeset/41122
> Why did you remove the "Remove All" (clear list) feature? I would think
> that's quite a useful feature. Also, I liked "Remove and put into Trash"
> better. This wording makes it clear that "Remove" alone just removes it
> from the list.

The "Remove and put into Trash" option came up on the i18n list and I 
started looking at these options. I think these changes make sense.

"Remove all" (Command-N) is redundant, since Command-A, Delete works just 
as well in the playlist window. Its a more useful pattern for the user to 
know/learn as it should work in most listviews of this kind. Additionally 
Alt-N has a strong connection to New (creation)- e.g "New Player..." in the 
main window. I think we should avoid using Command-N for actions that are 
on the opposite side of a creation-deletion spectrum, so to speak.

It works without a "Select All" menu item, but for completeness we should 
probably add it.

"Move to Trash" is worded to have a stronger connection to the "same" 
option in Tracker. (Removal from the playlist is secondary and implicit, 
compared to the brute immediacy of going "beyond" the playlist and actually 
moving the file to Trash.) I think it would have been worded more correctly 
as "put in Trash" rather than "put into Trash", but "Move to Trash" is more 
clear, and standard. Even if playlist removal isn't spelled out I think the 
user is likely to foresee it, or at least be able to explain it to himself 
after seeing the result.



Other related posts: