Re: DataGuard Weirdness

Hi Lee,
 
"we are still missing logs which have not been shipped onto the standby from 
the Primary."
 
If this statement holds true, then if you run the following statement on the 
primary and in the standby,you'll see differences in sequence#
 
-- primary 
 
select max(sequence#) from v$archived_log;
 
--standby
 
select max(sequence#) from v$archived_log where archived='YES';
 
Also check on the primary for archive log shipping error by running the 
following sql.
 
select dest_id,status,error from v$archive_dest where dest_id=2; (if you 
configure log_archive_dest_2 for the standby or use dest_id accordingly)
 
Thanks
Antony
 
 
________________________________
From: Robertson Lee - lerobe <Lee.Robertson@xxxxxxxxxx>
To: oracle-l@xxxxxxxxxxxxx 
Sent: Thursday, February 9, 2012 8:39 AM
Subject: DataGuard Weirdness

Guys,


Just set up an 11gR2 DG config (one primary/one standby) on Linux and am
seeing some strange errors in the standby alert log.....



Every now and again, (its fairly random) the following is happening.



RFS[278]: Selected log 5 for thread 1 sequence 29031 dbid 874073702
branch 764422822

Thu Feb 09 13:02:49 2012

RFS[278]: Selected log 5 for thread 1 sequence 29032 dbid 874073702
branch 764422822

Thu Feb 09 13:02:56 2012

Fetching gap sequence in thread 1, gap sequence 29030-29030

Thu Feb 09 13:03:49 2012

RFS[278]: Selected log 5 for thread 1 sequence 29033 dbid 874073702
branch 764422822

Thu Feb 09 13:04:48 2012

FAL[client]: Failed to request gap sequence

GAP - thread 1 sequence 29030-29030

DBID 874073702 branch 764422822

FAL[client]: All defined FAL servers have been attempted.

------------------------------------------------------------

Check that the CONTROL_FILE_RECORD_KEEP_TIME initialization

parameter is defined to a value that's sufficiently large

enough to maintain adequate log switch information to resolve

archivelog gaps.

------------------------------------------------------------



I have googled until I am sick and also been on My Oracle Support .
Everything points to a bug (which says has been fixed in 11g) as I have
tried all the various select statements from the internal views that
have been recommended on various web sites (and MOS) yet they all return
no rows which supposedly means all is fine. Despite this we are still
missing logs which have not been shipped onto the standby from the
Primary. 



Any ideas ?



Cheers

Lee

***************************************************************************
The information contained in this communication is confidential, is
intended only for the use of the recipient named above, and may be legally
privileged.

If the reader of this message is not the intended recipient, you are
hereby notified that any dissemination, distribution or copying of this
communication is strictly prohibited.

If you have received this communication in error, please resend this
communication to the sender and delete the original message or any copy
of it from your computer system.

Thank You.
****************************************************************************

--
http://www.freelists.org/webpage/oracle-l
--
http://www.freelists.org/webpage/oracle-l


Other related posts: