[haiku-commits] Re: haiku: hrev45134 - src/kits/tracker

  • From: Jérôme Duval <korli@xxxxxxxxxxxxxxxx>
  • To: haiku-commits@xxxxxxxxxxxxx
  • Date: Mon, 7 Jan 2013 13:46:57 +0100

2013/1/6  <humdingerb@xxxxxxxxxxxxxx>:
> 45f77dc: Renamed Tracker option "Don't move files to Trash" (#9352)
>
>   Renamed that option as it is the only negatively phrased to
>   "Move deleted files to Trash first" and also the option below
>   that to "Ask before deleting for good".
>   Also renamed every function name etc. in that regard and also
>   settings string of the Tracker settings file.
>
>                                         [ Humdinger <humdingerb@xxxxxxxxx> ]

There is a style issue below.
BTW the settings file isn't retro compatible, i.e. the old string
isn't taken into account. This kind of changes should be avoided.

Bye,
Jérôme

> diff --git a/src/kits/tracker/FSUtils.cpp b/src/kits/tracker/FSUtils.cpp
> index 040b2a4..b582118 100644
> --- a/src/kits/tracker/FSUtils.cpp
> +++ b/src/kits/tracker/FSUtils.cpp
> @@ -2842,9 +2842,9 @@ status_t
>  _DeleteTask(BObjectList<entry_ref>* list, bool confirm)
>  {
>         if (confirm) {
> -               bool dontMoveToTrash = 
> TrackerSettings().DontMoveFilesToTrash();
> +               bool MoveToTrash = TrackerSettings().MoveFilesToTrash();
>
> -               if (!dontMoveToTrash) {
> +               if (MoveToTrash) {
>                         BAlert* alert = new BAlert("",
>                                 B_TRANSLATE_NOCOLLECT(kDeleteConfirmationStr),
>                                 B_TRANSLATE("Cancel"), B_TRANSLATE("Move to 
> Trash"),

Other related posts: