[THIN] KB: CTX107237 - Wfshell.exe Fails to Launch in Users' Sessions

  • From: "Jim Kenzig Kenzig.com" <jkenzig@xxxxxxxxx>
  • To: thin@xxxxxxxxxxxxx
  • Date: Mon, 22 Aug 2005 06:54:17 -0700 (PDT)

 CTX107237 - Wfshell.exe Fails to Launch in Users' Sessions 

This document was published at: 
http://support.citrix.com/kb/entry.jspa?externalID=CTX107237 


Document ID: CTX107237, Created on: Aug 17, 2005, Updated: Aug 17, 2005 
Products: Citrix MetaFrame XP 1.0 for Microsoft Windows 2000, Citrix MetaFrame 
XP 1.0 for Microsoft Windows 2003, Citrix MetaFrame Presentation Server 3.0 for 
Microsoft Windows 2000, Citrix MetaFrame Presentation Server 3.0 for Microsoft 
Windows 2003 
 
Symptoms

Wfshell.exe is not launching in regular users? sessions.

Cause

Regular users may have lost permissions to the following registry key:

HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Install\{C05CE041-63DB-4467-B777-9FCB30013CA2}

Troubleshooting

1. Download the Regmon freeware utility from Sysinternals. 

2. Filter on wfshell.exe, then click Apply and OK.



3. The main Regmon window opens with logging enabled for the specified 
process(es).

4. Launch an application as a regular user.

5. Stop and save the trace. 

6. Clear the Regmon log.

7. Start the Regmon process for a filter on wfshell.exe, but logon as an 
administrator.

8. Compare a working log to a non-working log.

9. Open the non-working log and search for denied. In this example, wfshell was 
returning an ACCESS DENIED result for a regular user.



1144 108.31141663 wfshell.exe:2984 OpenKey 
HKLM\SOFTWARE\Citrix\Install\{C05CE041-63DB-4467-B777-9FCB30013CA2} ACCESS 
DENIED Access: 0x20019

10. Open the working log and note that administrators have permissions to that 
key.

Resolution

If the Everyone or Authenticated Users group has been removed, add it with read 
permissions, or add the users or groups that require access


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