[THIN] KB: CTX104200 - Could not start IMA Service in CTX_MF_IMA_StartIMAService

  • From: "Jim Kenzig http://thin.net" <jimkenz@xxxxxxxxxxxxxx>
  • To: thin@xxxxxxxxxxxxx
  • Date: Thu, 24 Jun 2004 09:59:45 -0400

CTX104200 - Could not start IMA Service in CTX_MF_IMA_StartIMAService

This document was published at:
http://support.citrix.com/kb/entry.jspa?externalID=CTX104200


Document ID: CTX104200, Created on: Jun 22, 2004, Updated: Jun 22, 2004

Products: Citrix MetaFrame Presentation Server 3.0 for Microsoft Windows
2000, Citrix MetaFrame Presentation Server 3.0 for Microsoft Windows 2003,
Citrix MetaFrame XP 1.0 for Microsoft Windows 2000, Citrix MetaFrame XP 1.0
for Microsoft Windows 2003

Symptom

MsiInstaller error:

?Could not start IMA Service in CTX_MF_IMA_StartIMAService.?

Cause

When installing a new MetaFrame server and joining an existing farm, the
installation fails and rolls back when starting the IMA Service.

The following error appears in the event viewer:

Event Type: Error

Event Source: MsiInstaller

Event Category: None

Event ID: 10005

Date: 2004-05-13

Time: 00:38:49

User: N/A

Computer: RETGB262-NT1000

Description: Product: Citrix MetaFrame XP Server for Windows with Feature
Release 3.
Error 26005. Could not start IMA Service in TX_MF_IMA_StartIMAService
State = 1

If you install the server with a local database and then try to join the
farm, the following message appears:

?Farm Membership was changed but with errors.?

However, your server however did successfully join the farm.

Resolution

This can happen if your data store is big or if there is a slow WAN link
between the MetaFrame server and the data store.

The IMA Service fails during the installation because the Service Control
Manager times -out.

If the IMA Service takes too long to start, the Service Control Manager
issues an error message that causes the installation to roll back.

You need to increase the time-out value of the Service Control Managers.

To do so, you need to add a value to the following registry key.

Caution! This fix requires you to edit the registry. Using Registry Editor
incorrectly can cause serious problems that may require you to reinstall
your operating system. Citrix cannot guarantee that problems resulting from
the incorrect use of Registry Editor can be solved. Use Registry Editor at
your own risk.

Go to
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ServicesPipeTimeout

Create the following value:

Name: ServicesPipeTimeout
Type: DWORD
Value: Decimal: 600000 (This value is milliseconds is equal to 10 minutes.
You can reduce this if you need to.)

Restart the server and begin the installation of MetaFrame.

Additional Information

For additional information, see the Microsoft Knowledgebase article at:

http://support.microsoft.com/default.aspx?scid=kb;en-us;839803

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