[haiku-commits] Re: r40896 - haiku/trunk/src/preferences/mail

  • From: "Axel Dörfler" <axeld@xxxxxxxxxxxxxxxx>
  • To: haiku-commits@xxxxxxxxxxxxx
  • Date: Thu, 10 Mar 2011 10:14:39 +0100 (MET)

Clemens<clemens.zeidler@xxxxxxxxxxxxxx> wrote:
> >> -  size_t readed = _ReadStringAt(string, fReadPosition);
> >> +  int32 readed = _ReadStringAt(string, fReadPosition);
> > Does _ReadString() actually return int32? Or is it ssize_t?
> returns int32 now should it be ssize_t?

ssize_t means: returns a size or a negative error code. So if that description 
fits, I would choose an ssize_t for clarity (even though it doesn't matter at 
this point, it might also make an actual difference on a 64bit platform, as 
ssize_t might be 64 bit then).


Other related posts: