[haiku-commits] Re: r38072 - haiku/trunk/src/servers/app

  • From: Stephan Assmus <superstippi@xxxxxx>
  • To: haiku-commits@xxxxxxxxxxxxx
  • Date: Fri, 13 Aug 2010 10:12:53 +0200

Hi,

On 2010-08-13 at 01:05:31 [+0200], clemens.zeidler@xxxxxxxxxxxxxx wrote:
> Author: czeidler
> Date: 2010-08-13 01:05:31 +0200 (Fri, 13 Aug 2010)
> New Revision: 38072
> Changeset: http://dev.haiku-os.org/changeset/38072
> 
> Modified:
>    haiku/trunk/src/servers/app/Desktop.cpp
>    haiku/trunk/src/servers/app/DesktopListener.cpp
>    haiku/trunk/src/servers/app/DesktopListener.h
> Log:
> Rework listener interface as suggested by Axel.
> 

> @@ -1229,7 +1225,7 @@
>          } else
>              window->MoveBy((int32)x, (int32)y);
>  
> -        InvokeMoveWindow(window);
> +        WindowMoved(window);
>          UnlockAllWindows();
>          return;
>      }

One more suggestion: The methods which forward the events to the listeners 
could be named "Notify*()". So in the case above "NotifyWindowMoved()". But 
only if the Desktop class does nothing besides notifying in those methods 
(which I think it should, otherwise it should just register a listener itself 
to do more stuff).

Best regards,
-Stephan

Other related posts: