[haiku-bugs] [Haiku] #8232: MacBook Pro, mouse, keyboard, sound and network fails.

  • From: "Dilbert2" <trac@xxxxxxxxxxxx>
  • Date: Fri, 09 Dec 2011 23:44:48 -0000

#8232: MacBook Pro, mouse, keyboard, sound and network fails.
 Reporter:  Dilbert2                             |        Owner:  mmlr
     Type:  bug                                  |       Status:  new
 Priority:  normal                               |    Milestone:  R1
Component:  Drivers/USB                          |      Version:  R1/alpha3
 Keywords:  Keyboard, mouse, network,            |   Blocked By:
  soundcard, touchpad, Mac, Macbook,             |  Has a Patch:  0
 Blocking:                                       |
 Platform:  All                                  |
 I have bought a second hand 13" '''Macbook Pro'''.
 Intel Core Duo, 4GB RAM, 2 USB ports.
 It works perfectly in Mac OSX Lion, so this is not a hardware issue.

 I want to use Haiku on this Mac.
 Booting macs from memory stick is really complicated, (or so I'm told,) so
 I boot it from a CD.

 I burn the R1A3 iso file to disc, put it into my Mac, and hold button "c"
 while it boots.
 Screen turns black and Haiku logo appears on the Mac.
 The seven grey icons below the Haiku logo also appear.

 Here's the first problem:
 Sometimes the seven grey icons just stay grey, and nothing more happens.
 If this happens, I just reboot and try again. Sometimes all seven icons
 get color, and Haiku loads.
 It asks about keymap and language. I click on Live CD, not Installer.

 Here's the second problem.
 I use a USB mouse.
 == The Mac's trackpad and keyboard show no sign of working at all. ==
 My USB mouse (Logitech Unifying wireless) is my only input device.
 Also, my Unifying USB keyboard does not work in Haiku on this Mac.
 So, I have no keys at all.
 The USB mouse works ''sometimes''.
 The last time I booted it, it worked for a few minutes, then stopped
 working, then it worked again, then it stopped working...........

 So, external USB mouse works good sometimes, but not always.
 Internal touchpad never works.
 Internal and external USB keyboard never works.

 Also, it does not care about memory sticks being inserted. No icon
 I know Haiku supports memory sticks, but it does not work on this Mac.

 And there is no network access, so I can't transfer syslog.
 I took a photo of syslog, but it's very long, and a picture can't contain

 Deskbar identifies my network card as /dev/net/broadcom570x/0
 It says Configuring and then Ready when plugged in, and No link when
 It knows when the network cable is connected, but does not work.
 WebPositive says "Can't resolve hostname" if I click on any of the links
 in the Welcome page.

 Also, if I click on the sound icon, It says "Could not find the mixer".

 So, no keyboard, no touchpad, no sound, sometimes USB mouse (it may work
 for a few minutes, then stop for a while, then resume working.....), no
 memory stick, no network connection (although it knows when the cable is
 inserted, and I know that cable works)...

Ticket URL: <http://dev.haiku-os.org/ticket/8232>
Haiku <http://dev.haiku-os.org>
Haiku - the operating system.

Other related posts: