[haiku-bugs] Re: [Haiku] #10169: Double Fault Exception on usb boot x86_64

  • From: "bonefish" <trac@xxxxxxxxxxxx>
  • Date: Sun, 10 Nov 2013 13:54:41 -0000

#10169: Double Fault Exception on usb boot x86_64
-----------------------------+----------------------------
   Reporter:  korli          |      Owner:  axeld
       Type:  bug            |     Status:  new
   Priority:  normal         |  Milestone:  R1
  Component:  System/Kernel  |    Version:  R1/Development
 Resolution:                 |   Keywords:
 Blocked By:                 |   Blocking:
Has a Patch:  0              |   Platform:  x86-64
-----------------------------+----------------------------

Comment (by bonefish):

 Regarding the variable naming, I would rename the old `stackWrappers` to
 `stackWrapperPool` (to match the naming of the actual variable) and go
 with `stackWrappers` for the new variable.

 I'd also merge the two allocation checks into a single `if`, like this:
 {{{
 PageWriteWrapper* wrapperPool = ... allocate ...
 PageWriteWrapper** wrappers = ... allocate ...
 if (wrapperPool == NULL || wrappers == NULL) {
   delete both
   use stack
 }
 }}}

--
Ticket URL: <http://dev.haiku-os.org/ticket/10169#comment:7>
Haiku <http://dev.haiku-os.org>
Haiku - the operating system.

Other related posts: