[wdmaudiodev] Re: Capture latency with USB card

Hi Pierre,

>With a USB audio device though, the minimum stable delay I can get is
>around 20-25 ms.
>The cause of the problem seems to be the instability of the capture side.
>I measure the time
>between capture events and I get delays up to 20ms on USB where it should
>be 5ms.
> 
>I am using Microsoft USB audio driver (latest version) and I heard that
>it can achieve better
>performance. Did anybody experienced such problems with USB audio? 
> 
I had similar experiences. The events I was waiting on were being signaled
at such uneven intervals that my latency was fairly unusable - it would
tick along regularly for a while (every few ms, corresponding to my buffer
size), then I'd suddenly get a delay which was greater by at least a
factor of 10. Although this problem seemed to be more significant when I
added capture, I don't recall verifying that it was explicitly because of
the capture side, as opposed to a result of running capture and render
together...

Sincerely,

Andrew Sherbrooke
Art & Logic
Lead Engineer, Audio/Media Development
asher@xxxxxxxxxxxx
www.artlogic.com


******************

WDMAUDIODEV addresses:
Post message: mailto:wdmaudiodev@xxxxxxxxxxxxx
Subscribe:    mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=subscribe
Unsubscribe:  mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=unsubscribe
Moderator:    mailto:wdmaudiodev-moderators@xxxxxxxxxxxxx

URL to WDMAUDIODEV page:
http://www.wdmaudiodev.de/

Other related posts: