[retroforth] Re: reuse word name?

  • From: Charles Childers <charles.childers@xxxxxxxxx>
  • To: retroforth@xxxxxxxxxxxxx
  • Date: Fri, 26 Nov 2004 07:15:28 -0500

The last message was sent by accident :-(

Basically, I'd like to clean up the core wordset a bit, so it seems
like a good time to evaluate what is and is not needed.

Possible removals:

1) columns
This was added for use with RetroForth/Native, but it could easily be
made part of the driver code and left out of the core.

2) lines
Added to allow "clear" to handle non 25-line displays without
recompiling. Should it be left in?

3) 2over
4) 2swap
These were added by cmbrannon a while back, but don't seem to be used
very often. And they require greater degrees of stack juggling than
I'd like.


Possible simplifications:
5) zt-make
I'd like a simpler way to handle this. Allocating space at HERE is ok,
but could the implementation could be a bit cleaner?

6) fill
7) words
8) $,
9) until
Suggestions for any of these would be welcome. They work, but may not
be clear enough. I feel that they could probably be cleaned up a
little, but I'm not sure how to proceed...


Possible additions:
10) literal,
 forth
: literal, m: literal ;

This would allow things like:
  : foo [ 30 fib literal, ]
to be done. It's debatable whether this is a good enough reason,
because we could also do:
  : foo [ 30 fib ] literal ;
Are there other valid uses for literal, that would make it worth adding?

11) r
This would be like R@ in most forths, and could be very useful in
larger programs. I dislike the R@ name because it implies a fetch from
TOR (top of return stack), which is _not_ what it does.


So please comment on these, I'd like to gauge opinions before making
any such major changes between releases. Other words that could be
eliminated, or simplified, or added, would be welcome for discussion
as well.

--
Charles

Other related posts: