[linux-muc] Re: kein kontakt zu router

  • From: Ulf Henninger <ulf.henninger@xxxxxxxxxxxxxxxx>
  • To: linux-muc@xxxxxxxxxxxxx
  • Date: Wed, 19 Dec 2007 11:46:22 +0100

Hallo,

Wird die Adresse statsch oder per DHCP zugewiesen? ( vielleicht mal den Output 
von cat /etc/network/interfaces posten )

Hintergrund: wenn das statisch passiert, heißt das gar nichts. Statisch kannst 
du alles zuweisen, auch ohne Verbindung zum Netzwerk zu haben. Bei DHCP mußt 
du irgendwann mal 'ne Netzwerkverbindung gehabt haben. Dann liegt dein 
Problem vermutlich nicht an der Karte, sondern an der Netzwerkkonfiguration.

Der Output von lspci könnte auch ganz interessant sein - da sollte deine Karte 
irgendwo auftauchen. 

Wenn DHCP: von wem? Ist der Router der DHCP-Server?

Gruß, Ulf

On Tuesday 18 December 2007 23:00:25 Joh_Borres@xxxxxx wrote:
> > -----Ursprüngliche Nachricht-----
> > Von: "Tobias Diedrich" <ranma+lugm@xxxxxxxxxxxx>
> > Gesendet: 18.12.07 20:38:57
> > An: Joh_Borres@xxxxxx
> > CC: linux-muc@xxxxxxxxxxxxx
> > Betreff: Re: [linux-muc] kein kontakt zu router
>
> Danke. Es sieht alles so aus wie vorgeschlagen. Es klappt allerdings immer
> noch nicht.
>
> Hat das vielleicht etwas mit
> /etc/init.d/networking
> /etc/init.d/netenv
> zu tun?
>
> > Joh_Borres@xxxxxx wrote:
> > > nun habe ich große Probleme, meinen neu installierten Rechner, mit dem
> > > Router ( arcor dsl - der router und arcor funktionieren; ein apple
> > > hängt da über wlan dran) zu verbinden.
> > >
> > > Das wiederum ist die Voraussetzung, das System upzudaten etc.
> > >
> > > Ich habe woody debian installiert.
> >
> > Warum nicht gleich etch?
> > Woody ist doch die alte stabile Version.
>
> Ich würde gerne ein update machen über das Internet.
>
> > > So richtig sicher, dass meine Karte (eth0) erkannt worden ist, bin ich
> > > nicht.
> > >
> > > ifconfig gibt folgenden output
> > >
> > > eth0   Link encap: Ethernet  HWaddr 00:50:22:F0:2A:E6
> > >           inet addr:192.168.1.45 Bcast:192.168.1.255 Mask:255.255.255.0
> > >           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
> > >           TX packets:6 errors:0 dropped:0 overrruns:0 carrier:0
> > >           collisions:0 txqueuelen:100
> > >           RX bytes:0 (0.0b) TX bytes: 360 (360.0 b)
> > >           Interrupt: 3 Base address:0x300
> > >
> > > Ist damit sicher, dass meine Netzwerkkarte erkannt worden ist?
> >
> > Er hat zumindest _eine_ Netzwerkkarte erkannt.  Wenn nur eine im
> > Rechner steckt, behaupte ich mal die hat er gefunden. ;)
> >
> > "ethtool -i eth0" kann dir etwas mehr verraten, z.B.:
> > |melchior:~# ethtool -i eth2
> > |driver: r8169
> > |version: 2.2LK-NAPI
> > |firmware-version:
> > |bus-info: 0000:01:07.0
>
> Das klappt bei mir nicht ethtool -i eth0 klappt bei mir nicht.
>
> > > Gebe ich route ein, gibt es folgenden output
> > >
> > > Destination  Gateway      Genmask       Flags  Metric  Ref   Use iface
> > > 192.168.02   *            255.255.255.0 UH     1       0       0 sl0
> > > localnet     *            255.255.255.0 U      0       0       0 eth0
> > > default      192.168.1.1  0.0.0.0       UG     0       0       0 eth0
> > > default      192.168.1.1  0.0.0.0       UG     0       0       0 sl0
> > > default      *            0.0.0.0       U      1       0       0 sl0
> >
> > Warum hast Du noch eine Defaultroute über sl0 zum Gateway?
> > sl0 klingt nach slip?
> >
> > Probier mal ein "ifconfig sl0 down".  Das sollte auch gleich die zum
> > sl0-Interface gehörigen routen entfernen, die dich hier wohl stören.
> >
> > Danach sollte es so aussehen:
> > |Destination  Gateway      Genmask       Flags  Metric  Ref   Use iface
> > |localnet     *            255.255.255.0 U      0       0       0 eth0
> > |default      192.168.1.1  0.0.0.0       UG     0       0       0 eth0
> >
> > Und damit sollte es an sich auch schon gehen.
>
> Sieht genau so aus, geht aber nicht.
>
> > Wenn es dann geht, solltest Du mal in der /etc/network/interfaces
> > nach der Zeile mit "auto " am Anfang suchen und dort das
> > "sl0"-Interface entfernen.
>
> /etc/network/interfaces
> iface eth0 inet static
> address 192.168.1.45
> netmask 255.255.255.0
> gateway 192.168.1.1
>
> > Vermutlich musst Du dann noch DNS in der /etc/resolv.conf
> >
> > einstellen, z.B. so:
> > |melchior:~# cat /etc/resolv.conf
> > |search local.dom.ain
> > |nameserver 192.168.1.1
> >
> > HTH,
> >
> > --
> > Tobias                                              PGP: 
> > http://9ac7e0bc.uguu.de
> > ã??ã?®ã?¡ã?Œã?«ã?¯å??å?²å??å?©ç?šã??ã??ã??ã??ã??ã??ã?§äœ?ã??ã??ã?Šã??ã?Ÿã
> >??ã??
>
> _________________________________________________________________________
> In 5 Schritten zur eigenen Homepage. Jetzt Domain sichern und gestalten!
> Nur 3,99 EUR/Monat! http://www.maildomain.web.de/?mc=021114
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> ~~ Info (Main-Site): http://www.linux-muc.de/
> ~~ Un/Subscribe: http://www.freelists.org/cgi-bin/list?list_id=linux-muc
> ~~ Archives http://www.freelists.org/archives/linux-muc/
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~



-- 
Mit freundlichen Grüßen / Kind regards

Ulf Henninger
nh3 technical consulting

Alter Teichweg 9
22081 Hamburg

Fon +49 40 2000 9581
Fax +49 40 2000 9582
Mail ulf.henninger@xxxxxxxxxxxxxxxx
Web http://www.nh3consulting.de
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~~ Info (Main-Site): http://www.linux-muc.de/
~~ Un/Subscribe: http://www.freelists.org/cgi-bin/list?list_id=linux-muc
~~ Archives http://www.freelists.org/archives/linux-muc/
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Other related posts: