[ExchangeList] Re: use dynamic ip address for mail server

  • From: "Rick Boza" <rickb@xxxxxxxxxxxxxxx>
  • To: <exchangelist@xxxxxxxxxxxxx>
  • Date: Tue, 3 Oct 2006 14:41:47 -0400

I think it's risky, and certainly isn't a best practice, but should
work.  See http://www.amset.info/exchange/dynamicip.asp and
http://www.msexchange.org/tutorials/MF002.html for short guides.  I
would imagine there could be delivery delays from time to time if you
get between updates.  I suppose its also possible you could lose some
mail if somehow you wound up where someone else with an SMTP server gets
your old IP address, and rejects the message as undeliverable...but that
seems really unlikely.


I can also see you getting rejected by some orgs doing a reverse lookup,
they may not like you redirecting from mail.domain.com to


Having said that, personally I think a much better solution would be to
put the server somewhere that you can support a static address, and
point the clients to it via RPC/HTTPS.  


Plus, static addressing isn't that expensive anymore - what's the price
difference?  With Sprint I think the difference runs around $20 / month.
When talking to clients that insist  they can't afford to do something
according to a best practice, maybe they need a different solution?


Just my random thoughts, anyhow.




Rick Boza




Manage Your Mobile Workforce!





From: exchangelist-bounce@xxxxxxxxxxxxx
[mailto:exchangelist-bounce@xxxxxxxxxxxxx] On Behalf Of Ara Avvali
Sent: Tuesday, October 03, 2006 2:22 PM
To: exchangelist@xxxxxxxxxxxxx
Subject: [ExchangeList] use dynamic ip address for mail server




We want to host a mail server at a DSL line which is dynamic. Getting
static will cost a lot of money at the location so we got a linksys
router that support dyndns.org and created a record for
domain.dyndns.org. Put the router in front of mail server and forwarded
tcp 25 to mail server. Then we create a CNAME in DNS server that
mail.domain.com points to domain.dyndns.org. Then there is an MX record
with 10 priority mail.domain.com.

Would this work? It is almost 24 hours and dnsreport still says there is
no proper mx record configured. 

I appreciate any help on this one

Other related posts: