Re: V$OBJECT_USAGE view for indexes in all schemas

Works for me, albeit on 9.2.0.1.0 on W2K:

SQL*Plus: Release 9.2.0.1.0 - Production on Mon May 17 15:01:42 2004

Copyright (c) 1982, 2002, Oracle Corporation.  All rights reserved.

SP2-0640: Not connected
SQL> connect / as sysdba
Connected.
SQL> grant select on sys.object_usage to scott;

Grant succeeded.

SQL> grant select on sys.object_usage to public;

Grant succeeded.

SQL>

Maybe it's another 9.2.0.5 bug? The fact that you get an ORA-600 error is 
suspicious.

At 02:47 PM 5/17/2004, you wrote:
>Hey all,
>
>So, I create my own view <BZZZZT!>.  I can't because the =
>SYS.OBJECT_USAGE table cannot be changed, apparently including GRANTs.  =
>I'd paste the error here, but when I try it again, I get an ORA-600.  =
>Oracle's solution is to create a new V$ view in SYS.  I make it a habit =
>to not mess with SYS unless I have to.
>
>
>Rich Jesse                        System/Database Administrator

regards

Wolfgang Breitling
Centrex Consulting Corporation
http://www.centrexcc.com 

----------------------------------------------------------------
Please see the official ORACLE-L FAQ: http://www.orafaq.com
----------------------------------------------------------------
To unsubscribe send email to:  oracle-l-request@xxxxxxxxxxxxx
put 'unsubscribe' in the subject line.
--
Archives are at http://www.freelists.org/archives/oracle-l/
FAQ is at http://www.freelists.org/help/fom-serve/cache/1.html
-----------------------------------------------------------------

Other related posts: