RMAN recovery incomplete issue while recovering in DG

Hi All,

We are having the issue with dataguard lag issue from production due to
heavy generation of archives and had a challenge to keep in synch of DG with
production database. We later tried to use the manual recovery option to see
if we can make the recovery faster rather than script which ships the
archive and then get applied, but it did not help. Finally we tried with
RMAN option like creating a catalog database and registering the DG as
level0 (since its 9.2.0.8 version) and taking level 1 at production side and
later have the backup piece in DG host to apply RMAN with "recover database
no redo".
We are facing challenge in this where RMAN did not errored out in any
stage/phase but only few datafiles got updated with the latest SCN and rest
were left untouched by RMAN.
Also if the Oracle is on 10g we just need a level1 backup and apply the
changes in DG database without any level0 catalog.

What we observed was, there were 27 total backup pieces were generated in
level1 backup, but first 10 backup pieces were not cataloged and looks
missing (wierd).

1.     The recovery noredo has not applied any changes to the files which
are dated 22-FEB and few 28-FEB.

1.     When you start recovery in manual mode, it asks for archive files
generated on Feb22


1.     The backupsets which are not listed in RMAN catalog but exists in
physical media is of *Size 0* in the rman catalog.  *The first 10
backupsets are kicked out*. But the backup piece is in available status and
the files returns no rows.



RMAN> *list backupset 198935;*



List of Backup Sets

===================



BS Key  Type LV Size       Device Type Elapsed Time Completion Time

------- ---- -- ---------- ----------- ------------ ---------------

198935  Incr 1  0          DISK        00:50:01     01-MAR-11

        BP Key: 198569   Status: AVAILABLE   Tag: SCPSTBY
        Piece Name: /oracle/product/9.2.0.8/rman/2pn63c7m


RMAN> *list backup of datafile "/dev/vgssoprd7/rv4000-63";*

returns No rows.



Looks like  some threshold value of control is getting hit and the first
files/backupsets are kicked out when new files/backupsets are generated.



1.     Checked if it’s the file size which is causing issue but it is not as
other big files were taken and applied.


Need your help in showing some ideas and light on the same as its 9i version
and having challenges.

Database version : 9.2.0.8
Platform              : HP-UX

Thanks,
Ananth

Other related posts: