[zxspectrum] Test funzionamento cloni FPGA

  • From: Alessandro Dorigatti <adorigatti@xxxxxxxxx>
  • To: zxspectrum@xxxxxxxxxxxxx
  • Date: Thu, 31 Mar 2011 22:37:57 +0200

Ciao,
ho cambiato il titolo del thread perchè mi sembrava che ormai "ULA+"
fosse fuori luogo.

On Thu, 2011-03-31 at 14:07 +0200, Luca Bisti wrote:
> Il 31/03/2011 12.50, Alessandro Dorigatti ha scritto:
> > Ciao Luca,
> > capendo perfettamente il "massacro lavorativo", aggiungo solo un
> > dettaglio: a me la seconda parte di Shock Megademo (quella con le
> > righette orizzontali che scorrono e con overscan) funziona
> > perfettamente, o almeno non noto differenze di sorta rispetto a quanto
> > visibile in Fuse. Aggiungo che anche tutti gli altri pezzi del Mega Demo
> > non presentano malfunzionamenti di sorta!
> 
> Caspita, allora sei davvero un pezzo avanti! Probabilmente si tratta 
> davvero di scovare l'istruzione "sbagliata" o poco più.
> Nel frattempo che mi dici di NMI 3 demo (la parte con i multicolor 
> orizzontali a tutto schermo)

Ho appena provato NMI 3. La parte 3) (WHATSA DXYCP), che credo sia
quella a cui ti stai riferendo, si comporta esattamente come nel Fuse.
A tal proposito noto che:

1) Nel caso di modalità 48K sync mode (quella che dovrebbe impostare il
timing corretto per lo Spectrum 48K) la prima colonna dello schermo
"paper" (non "border") ha i colori leggermente sfasati verticalmente.
Per capire esattamente cosa voglio dire non posso che chiedere di
provare FUSE. Questo "difetto" si nota anche nello Spectrum 48K REALE?

Aggiungo, però, che tenendo premuto il tasto "2" (che imposta la
modalità 48K) e rilasciandolo (alcune volte) riesco ad ottenere un
"flickering" del suddetto difetto (che oscilla a circa 5-6Hz in questo
caso) ciclando tra colore "sfasato" e colore "allineato al resto delle
righe orizzontali". Devo dire che questa instabilità non è riproducibile
con Fuse (ovvero: anche in Fuse provo a tenere premuto il tasto "2",
mentre tengo premuto lo sfasamento flickera, quando rilascio "2" si
stabilizza sempre in condizione sfasata "stabile").

2) Nel caso di modalità 128K sync mode, noto (a meno di particolari che
mi possano sfuggire) la stessa "distribuzione" di colori. Tra l'altro
noto anche lo stesso "flickering" di tre gruppi di pixel nelle righe 1,
3 e 5 dello schermo "paper" (verso l'estrema destra dello schermo
"paper"). Anche qui per capire cosa intendo è necessario provare con
Fuse.

Dagli effetti che vedo, immagino (ma qui vorrei una conferma) che nel
caso 1) le righe dovrebbero essere tutte uniformi (senza quell'effetto
sfasamento che ottengo sia io che il Fuse). Mi potete confermare questo
fatto?

>  e di NMI 2 (ultima parte)?

Come anticipato prima, ho riprovato NMI2. Noto una perfetta coerenza con
quanto mostrato da Fuse. L'ultima parte in particolare mostra un bel po'
di "confusione" di colori intorno alla scritta "NMI" in alto al centro
(stessa "confusione" si nota in Fuse). Su uno Spectrum reale l'effetto è
analogo a quello visualizzato da Fuse?

Mi spiace di non poter provare in prima persona su uno Speccy reale...
ma tant'è...

Alessandro


Other related posts: