[zxspectrum] Re: Aiuto per riparare ZX Spectrum 48k

  • From: Ciccio Morelli <cicciomorelli@xxxxxx>
  • To: zxspectrum@xxxxxxxxxxxxx
  • Date: Thu, 5 Mar 2020 16:48:39 +0100

Penso di poterlo sostituire, grazie per tutti i consigli. 

Ciccio

Inviato da iPhone

Il giorno 5 mar 2020, alle ore 16:09, Claudio Di Cesare 
<claudio.dicesare@xxxxxxxxx> ha scritto:


Una scheda diagnostica la vende ByteDelight 
(https://www.bytedelight.com/?product=zx-diag-cart-diy-kit) però ti domando: 
sei in grado di dissaldare eventuali chip e sostituirli?
Se lo Z80 l'hai cambiato tu, penso di si, ma allora il chip danneggiato (se è 
quello) lo puoi identificare anche provando a vedere se c'è ne' uno più caldo 
di altri. In questo caso lo dissaldi e sostituisci con uno compatibile, con 
la stessa velocità (mi sembra 20ns).
Se non pensi di saperlo fare, magari è meglio spedire la motherboard a 
qualcuno che può occuparsi di sistemarla.

      Mail priva di virus. www.avast.com

Il giorno gio 5 mar 2020 alle ore 15:56 Ciccio Morelli 
<cicciomorelli@xxxxxx> ha scritto:
Come scheda di diagnostica hai suggerimenti? 
Dove la trovo?
Con la DivMMC non posso fare niente?
Grazie

Inviato da iPhone

Il giorno 5 mar 2020, alle ore 15:28, Claudio Di Cesare 
<claudio.dicesare@xxxxxxxxx> ha scritto:


Ok, allora il problema è al di sopra dei 16k
- O i chip dei 32K RAM (sono gli 8 TMS4532 in 2 gruppi da 4)
- O la decodifica, i 4 TTL tra la ULA e lo Z80, di cui due sono sotto 
l'aletta di raffreddamento
Però con una scheda di diagnostica si potrebbe identificare il chip esatto 
e fare una sostituzione mirata.


    Mail priva di virus. www.avast.com

Il giorno gio 5 mar 2020 alle ore 15:23 Ciccio Morelli 
<cicciomorelli@xxxxxx> ha scritto:
Ok, scusa ma non sono pratico...
Come risposta mi da 8706

Inviato da iPhone

Il giorno 5 mar 2020, alle ore 15:13, Claudio Di Cesare 
<claudio.dicesare@xxxxxxxxx> ha scritto:


Okkio,
USR è una parola chiave del Sinclair Basic, non devi digitare le tre 
lettere ma CapsShift+SymbolShift e poi il tasto L.
Riprova

Il gio 5 mar 2020, 15:05 Ciccio Morelli <cicciomorelli@xxxxxx> ha scritto:
Digitando PRINT 65536 - USR 7962 mi risponde
2 Variable not found, 0:1
Vi allego le foto aggiornate, per quanto riguarda le zone cerchiate da 
Pierpaolo mi sembra che le piste sotto non ci siano proprio quindi non 
mi sembra un difetto o una rottura.
Ipotizzando siano le RAM, scusate l’ignoranza ma quali chip sono? :-)))
Dove le posso reperire?
Grazie




Inviato da iPhone

Il giorno 5 mar 2020, alle ore 13:00, Claudio Di Cesare 
<claudio.dicesare@xxxxxxxxx> ha scritto:


Bene,
Dalla foto possiamo dire che è una 48k, sei sicuro che hai cambiato lo 
z80?

Prova a digitare quanto segue:

PRINT 65536 - USR 7962

Se ottieni 41473 è un 48k e almeno il Ramtop è corretto (ma non vuol 
dire che tutta la memoria è buona) 
Se ottieni 8912 vede solo i primi 16k e il problema potrebbe essere in 
un chip di ram difettoso o negli integrati TTL che si occupano della 
decodifica (i 4 vicini allo z80) 


Il gio 5 mar 2020, 12:38 Pierpaolo T <realjoker@xxxxxxxxx> ha scritto:
splendida!! bei ricordi!

Il giorno gio 5 mar 2020 alle ore 12:35 Ciccio Morelli 
<cicciomorelli@xxxxxx> ha scritto:
Ecco la foto della motherboard.

<231b90e7-9b17-4580-9735-565790a07a5b.jpg>

Inviato da iPhone

Il giorno 5 mar 2020, alle ore 12:10, Ciccio Morelli 
<cicciomorelli@xxxxxx> ha scritto:

Faccio una foto e ve la invio quanto prima.
Grazie per la disponibilità!

Inviato da iPhone

Il giorno 5 mar 2020, alle ore 10:46, Claudio Di Cesare 
<claudio.dicesare@xxxxxxxxx> ha scritto:


Ciao Ciccio,
Benvenuto, una domanda banale, sei sicuro che il modello acquistato 
sia un 48k?
Non è che sulla motherboard ci sono zoccoletti vuoti?
Magari mandaci una foto della motherboard. 
Ciao

Claudio 

Il gio 5 mar 2020, 10:11 Pierpaolo T <realjoker@xxxxxxxxx> ha 
scritto:
Benvenuto Ciccio, 

direi che questo gruppo è il posto migliore dove chiedere! ;-)

Pierpaolo

Il giorno gio 5 mar 2020 alle ore 09:59 Enrico Maria Giordano 
<e.m.giordano@xxxxxxxxxxxxxxx> ha scritto:


Il 05/03/2020 08:46, Ciccio Morelli ha scritto:

Buongiorno a tutti mi chiamo Stefano “Ciccio” Morelli,

Buongiorno a te e piacere di averti fra noi.

mi sono iscritto a questa mailing list per avere un aiuto da 
parte
vostra se possibile.
L'avrai sicuramente.

Ho comprato un vecchio ZX Spectrum 48k in un mercatino e
apparentemente sembrava funzionare, in realtà caricava un solo 
gioco
da cassetta che è Cookie e credo sia per il 16k. Poi mi sono 
comprato
una DivMMC Enjoy PRO ONE e ho sostituito lo ZX80 perché non
funzionava la cartuccia. Ora la cartuccia funziona con tutti i 
16k ma
non con le altre applicazioni per 48k, è evidente che c’è un 
guasto.
Mi potete aiutare? Esiste un modo di identificare il componente
guasto? Esiste già una guida su internet? Ne avete già parlato 
in
precedenza?
Ovviamente potrebbe essere la RAM, e precisamente uno dei chip 
dei 32k 
superiori. Ma lascio la parola ad Andrea Vavassori e altri.

Scusate se ho sbagliato la finalità del gruppo...

Non hai sbagliato niente. Qualsiasi cosa che riguardi lo Spectrum 
è qui 
bene accetta (ma anche qualche OT interessante, entro certi 
limiti).

EMG

http://www.emagsoftware.it
http://www.emagsoftware.it/emgmusic
http://www.emagsoftware.it/spectrum
http://www.emagsoftware.it/tbosg


<image0.jpeg>
<image1.jpeg>


    Mail priva di virus. www.avast.com

Other related posts: