[yoshimi] Re: Opinions Please

  • From: Kristian Amlie <kristian@xxxxxxxxxx>
  • To: yoshimi@xxxxxxxxxxxxx, ZB <zbigniew2011@xxxxxxxxx>
  • Date: Sat, 10 Nov 2018 14:08:50 +0100

On 10.11.2018 13:04, ZB wrote:

On Sat, Nov 10, 2018 at 11:37:38AM +0000, Will Godfrey wrote:

I'm looking at ways to make Yoshimi as inviting and easy to use as possible 
for
complete beginners and one of the stumbling blocks seems to be initially
getting any sound.

Currently, at first time startup Yoshimi defaults to JACK MIDI and audio, but
should it perhaps be ALSA for both?

I don't think so.

Yoshimi is for (wannabe :) musicians - it's not video player, that can be
used even by kids not being quite aware, what are they doing, and just
expecting "it'll work somehow". I believe every intending Yoshimi user is
aware what jackd is for and why (most probably) (s)he'll need it.

I agree. I would find it rather odd if a new synth I was considering
chose ALSA first, makes it seem less professional. If you want something
like Yoshimi, then you're likely already into pro audio and Jack.

Also, none of my systems have pulse audio installed (and never will) so
I don't know if that causes any difficulties - we don't have a specific
driver for that.

I noticed I have, for example, to close "pulseaudio volume setting" first,
but it's not Yoshimi-related - jackd doesn't like it. Slackware 14.2.

Indeed, the pure ALSA backend doesn't have this issue, it's only when
attempting to start jackd through the Jack backend.

-- 
Kristian
Yoshimi source code is available from either: 
https://sourceforge.net/projects/yoshimi
Or: https://github.com/Yoshimi/yoshimi
Our list archive is at: https://www.freelists.org/archive/yoshimi
To post, email to yoshimi@xxxxxxxxxxxxx

Other related posts: