[wdmaudiodev] Re: virtual audio driver removed via devcon, but it's only hidden

  • From: "Matthew van Eerde" <dmarc-noreply@xxxxxxxxxxxxx> (Redacted sender "Matthew.van.Eerde" for DMARC)
  • To: "wdmaudiodev@xxxxxxxxxxxxx" <wdmaudiodev@xxxxxxxxxxxxx>
  • Date: Tue, 16 Oct 2018 13:57:29 +0000

How am I supposed to figure out the answer to your question without logs?

________________________________
From: wdmaudiodev-bounce@xxxxxxxxxxxxx <wdmaudiodev-bounce@xxxxxxxxxxxxx> on 
behalf of Johannes Freyberger <jfreyberger@xxxxxxxxxxxxxxxxxxxx>
Sent: Monday, October 15, 2018 11:12:04 PM
To: wdmaudiodev@xxxxxxxxxxxxx
Subject: [wdmaudiodev] Re: virtual audio driver removed via devcon, but it's 
only hidden

Hi all,

apart from the “feedback hub” discussion I’d appreciate to get back to my 
initial request. As described the driver is in hidden state also after a reboot 
although setupapi.dev.log says it has been successfully removed. Are there any 
answers to my questions in my first post (see below)?

Thanks and best regards,
Johannes

De : wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx
[mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx] De la part de Johannes Freyberger
Envoyé : samedi 13 octobre 2018 08:37
À : wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Objet : [wdmaudiodev] virtual audio driver removed via devcon, but it's only 
hidden

Hi all,

when I’m uninstalling my pure virtual audio driver on some W10, 1803 machines 
via devcon remove the driver the driver doesn’t seem to be uninstalled 
completely as it is still visible as hidden device in the device manager even 
after a reboot. But in setupapi.dev.log the corresponding entry says:

 [Delete Device - ROOT\MEDIA\0006]
 Section start 2018/10/12 09:52:11.354
      cmd: "C:\Program Files (x86)\MyApplication\devcon.exe" remove *MyDriver
     dvi: Query-and-Remove succeeded
<<<  Section end 2018/10/12 09:52:12.031
<<<  [Exit status: SUCCESS]

On some other machines the drivers are completely gone and not in hidden state.

Could this “hidden driver” effect be due to user privileges or some Antivir 
software installed on these machines?
What makes an uninstalled driver go into this hidden state and can this have 
any subsequent negative effects if I’m installing a new version of my driver 
while the old version is still in this hidden state?
Could this be something which is new since the 1803 update as I don’t think 
I’ve seen this before?

Thanks and best regards,
Johannes Freyberger


Other related posts: