[wdmaudiodev] Re: virtual audio driver removed via devcon, but it's only hidden

  • From: "Matthew van Eerde" <dmarc-noreply@xxxxxxxxxxxxx> (Redacted sender "Matthew.van.Eerde" for DMARC)
  • To: "wdmaudiodev@xxxxxxxxxxxxx" <wdmaudiodev@xxxxxxxxxxxxx>
  • Date: Mon, 15 Oct 2018 15:26:51 +0000

  *   The feedback hub is useless if there is no-one to read it and check the 
problem and correct it

Sure. Luckily, there *are* people to read it and check the problem and correct 
it.

You can post questions about Windows audio APIs to the Windows Desktop 
Pro-Audio Application Development forum
https://social.msdn.microsoft.com/Forums/en-US/home?forum=windowspro-audiodevelopment&filter=alltypes&sort=lastpostdesc

From: Vincent Burel (VB-Audio)<mailto:vincent.burel@xxxxxxxxxxxx>
Sent: Monday, October 15, 2018 12:13 AM
To: wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] Re: virtual audio driver removed via devcon, but it's 
only hidden

Well, we are talking about bugs that are present since years,
And some are there since WIN7 (I even talked about WASAPI bugs on this list 
that are present since VISTA)
So no, you cannot say that your company cares about Audio.

I thank you for your personal effort, but as I already suggested, the feedback 
hub is useless if there is no-one to read it and check the problem and correct 
it.
It’s like the story about HLK certification, it’s just showing the 
way…Microsoft build an audio driver official example, Microsoft build a 
certification process, mandatory to sign this driver, and no-one at Microsoft 
is checking that SYSVAD is passing the HLK tests !?! Madness ?

Anyway I’ve played recently with IAudioSessionManager2, IAudioSessionControl 
etc… and I have 2 or 3 questions about this (totally bugged btw).
Since I saw you have GitHub for an example of code on these interfaces, let me 
know where do you prefer I put my questions ?

Regards
Vincent Burel


De : wdmaudiodev-bounce@xxxxxxxxxxxxx [mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx] ;
De la part de Matthew van Eerde (Redacted sender "Matthew.van.Eerde" for DMARC)
Envoyé : samedi 13 octobre 2018 13:13
À : wdmaudiodev@xxxxxxxxxxxxx
Objet : [wdmaudiodev] Re: virtual audio driver removed via devcon, but it's 
only hidden


  *   Microsoft does not care about this

Yes we do


  *   Please post a request in Feedback Hub

We say this because we want the log files so we can see what happened


From: wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx
<wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx>> on 
behalf of Vincent Burel (VB-Audio) 
<vincent.burel@xxxxxxxxxxxx<mailto:vincent.burel@xxxxxxxxxxxx>>
Sent: Saturday, October 13, 2018 12:14:52 AM
To: wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] Re: virtual audio driver removed via devcon, but it's 
only hidden

Hello,

The problem is there since WIN7 and it seems the reboot is finalizing the 
uninstallation (this is the only way we found to be sure about the audio driver 
de-installation) .
…with WIN10 there is additional problems regarding driver 
installation/de-installation, especially re-installation (used by WIN10 
automatic update).

Also devcon.exe seems to be bugged and can install 2 instances of your audio 
driver, the instance will be marked as disabled, but de-installation won’t be 
clear anyway if you don’t de-install manually the disabled occurrence of your 
driver…

Microsoft does not care about this and the only reply will get is “please post 
a request in feedback hub”

Regards
Vincent Burel

De : wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx
[mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx] De la part de Johannes Freyberger
Envoyé : samedi 13 octobre 2018 08:37
À : wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Objet : [wdmaudiodev] virtual audio driver removed via devcon, but it's only 
hidden

Hi all,

when I’m uninstalling my pure virtual audio driver on some W10, 1803 machines 
via devcon remove the driver the driver doesn’t seem to be uninstalled 
completely as it is still visible as hidden device in the device manager even 
after a reboot. But in setupapi.dev.log the corresponding entry says:

 [Delete Device - ROOT\MEDIA\0006]
 Section start 2018/10/12 09:52:11.354
      cmd: "C:\Program Files (x86)\MyApplication\devcon.exe" remove *MyDriver
     dvi: Query-and-Remove succeeded
<<<  Section end 2018/10/12 09:52:12.031
<<<  [Exit status: SUCCESS]

On some other machines the drivers are completely gone and not in hidden state.

Could this “hidden driver” effect be due to user privileges or some Antivir 
software installed on these machines?
What makes an uninstalled driver go into this hidden state and can this have 
any subsequent negative effects if I’m installing a new version of my driver 
while the old version is still in this hidden state?
Could this be something which is new since the 1803 update as I don’t think 
I’ve seen this before?

Thanks and best regards,
Johannes Freyberger


PNG image

Other related posts: