[wdmaudiodev] Re: Win 10 sets new Audio device as DEFAULT

  • From: "HpW-Works Support" <support@xxxxxxxxxxxxx>
  • To: <wdmaudiodev@xxxxxxxxxxxxx>
  • Date: Mon, 01 May 2017 17:55:41 +0000

Thank you so far

What is the solution.. means the answer for RME :D ... while connection an USB device for bench testing this will be happen all the time..?

Best Regards
Hp. Widmer

HpW-Works Support

Mailto:support@xxxxxxxxxxxxx
Website:http://www.hpw-works.com



On 1 May 2017 16:41:43 "Matthew van Eerde" <dmarc-noreply@xxxxxxxxxxxxx> (Redacted sender "Matthew.van.Eerde" for DMARC) wrote:

The Analog device is USB, so it trumps the internal “speaker/hp” device. Every time you install a new driver, Windows sees it as a brand new device.

From: HpW-Works Support<mailto:support@xxxxxxxxxxxxx>
Sent: Monday, May 1, 2017 9:38 AM
To: wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] Re: Win 10 sets new Audio device as DEFAULT


Attached the output after I did the change to the Realtek manually... or if required on
fresh install ??

Best Regards
Hp. Widmer

HpW-Works Support

Mailto:support@xxxxxxxxxxxxx
Website:http://www.hpw-works.com<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.hpw-works.com&data=02%7C01%7CMatthew.van.Eerde%40microsoft.com%7C2af3adb6bd14430acf5108d490b081e7%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636292535158156259&sdata=q3N8dgRJIXB95KqFcNYWGMjymHpB9K1cI984nQCgyMY%3D&reserved=0>

On 1 May 2017 15:56:14 "Matthew van Eerde" <dmarc-noreply@xxxxxxxxxxxxx> (Redacted sender "Matthew.van.Eerde" for DMARC) wrote:
Can you send the output of this utility?

https://blogs.msdn.microsoft.com/matthew_van_eerde/2014/03/24/troubleshooting-default-audio-device-heuristics/<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fblogs.msdn.microsoft.com%2Fmatthew_van_eerde%2F2014%2F03%2F24%2Ftroubleshooting-default-audio-device-heuristics%2F&data=02%7C01%7CMatthew.van.Eerde%40microsoft.com%7C2af3adb6bd14430acf5108d490b081e7%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636292535158156259&sdata=ODwFsSSG7Lq4jSzZekdGme21sEjdRJOIEslMNiRM78I%3D&reserved=0>

There is an .inf setting to make an audio device ineligible to be the default, but that seems heavy-handed

https://msdn.microsoft.com/en-us/library/windows/hardware/ff537750(v=vs.85).aspx<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmsdn.microsoft.com%2Fen-us%2Flibrary%2Fwindows%2Fhardware%2Fff537750(v%3Dvs.85).aspx&data=02%7C01%7CMatthew.van.Eerde%40microsoft.com%7C2af3adb6bd14430acf5108d490b081e7%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636292535158156259&sdata=n8JpI%2FrLtwo34%2FBkAVYJW1t5tL2fYMNdGtFPlVGIuJ4%3D&reserved=0>

From: HpW-Works Support<mailto:support@xxxxxxxxxxxxx>
Sent: Monday, May 1, 2017 8:53 AM
To: wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] Re: Win 10 sets new Audio device as DEFAULT

Hmmm

The current answer from RME is:

Its Windows 10 itself... so I am puzzled.. while they use the given MS
driver installer...

Any comment to get ride of this is welcome... or it is a inf setting?

Best Regards
Hp. Widmer

HpW-Works Support

Mailto:support@xxxxxxxxxxxxx
Website:http://www.hpw-works.com



On 1 May 2017 15:32:25 Tim Roberts <timr@xxxxxxxxx> wrote:

HpW-Works Support wrote:
Each time I install a new RME ADI-2 Pro driver... the new RME Audio device
gets on record & play as the default.

How to overcome of this while sets my skype stuff to the false device!

What you need to do is complain to RME.  They assume that their device
is the most important thing you will every install.  Their installer, at
the very least, should have an option to let you choose whether to make
itself the default.

--
Tim Roberts, timr@xxxxxxxxx
Providenza & Boekelheide, Inc.

******************

WDMAUDIODEV addresses:
Post message: mailto:wdmaudiodev@xxxxxxxxxxxxx
Subscribe:    mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=subscribe
Unsubscribe:  mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=unsubscribe
Moderator:    mailto:wdmaudiodev-moderators@xxxxxxxxxxxxx

URL to WDMAUDIODEV page:
https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.wdmaudiodev.com%2F&data=02%7C01%7Cmatthew.van.eerde%40microsoft.com%7C21219571861b4642fd2908d490aa280f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636292507896647075&sdata=NYf056mBkueDUOQUEGTeXP17uNh7T%2FnUZTty%2BIwznWY%3D&reserved=0



******************

WDMAUDIODEV addresses:
Post message: mailto:wdmaudiodev@xxxxxxxxxxxxx
Subscribe:    mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=subscribe
Unsubscribe:  mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=unsubscribe
Moderator:    mailto:wdmaudiodev-moderators@xxxxxxxxxxxxx

URL to WDMAUDIODEV page:
https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.wdmaudiodev.com%2F&data=02%7C01%7Cmatthew.van.eerde%40microsoft.com%7C21219571861b4642fd2908d490aa280f%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636292507896647075&sdata=NYf056mBkueDUOQUEGTeXP17uNh7T%2FnUZTty%2BIwznWY%3D&reserved=0


Other related posts: