[wdmaudiodev] Re: USB Audio Class 2 driver and MIDI

  • From: "Matthew van Eerde" <dmarc-noreply@xxxxxxxxxxxxx> (Redacted sender "Matthew.van.Eerde" for DMARC)
  • To: "wdmaudiodev@xxxxxxxxxxxxx" <wdmaudiodev@xxxxxxxxxxxxx>
  • Date: Mon, 18 Dec 2017 22:53:07 +0000

We’re looking at your logs and we need some more information. Can you send the 
USB descriptor of the device?


  1.  Run UsbView 
https://docs.microsoft.com/en-us/windows-hardware/drivers/debugger/usbview
  2.  Go to the Options menu and make sure “Show Config Descriptors” is checked
  3.  Click on the port that the USB device is plugged into
  4.  Right-click on the right half of the screen where the text is | Select All
  5.  Right-click again | Copy
  6.  Paste into a text file or email and send to me

________________________________
From: wdmaudiodev-bounce@xxxxxxxxxxxxx <wdmaudiodev-bounce@xxxxxxxxxxxxx> on 
behalf of Matthew van Eerde <dmarc-noreply@xxxxxxxxxxxxx>
Sent: Friday, November 17, 2017 8:33:43 AM
To: wdmaudiodev@xxxxxxxxxxxxx
Subject: [wdmaudiodev] Re: USB Audio Class 2 driver and MIDI

The internal bug number is 14610254 which may help you if you want to create a 
support incident.

From: Franz Detro<mailto:franz.detro@xxxxxxxxxxxxxxxxxxxxx>
Sent: Friday, November 17, 2017 1:23 AM
To: wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] Re: USB Audio Class 2 driver and MIDI

Hello Matthew,

do you have any news on this?



OK, please file a problem report in Feedback Hub; use Hardware, Devices, and 
Drivers | Audio and sound; once filed use the “Share” widget to send me a 
direct link.

https://aka.ms/Cgbvl7<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Faka.ms%2FCgbvl7&data=02%7C01%7CMatthew.van.Eerde%40microsoft.com%7Ceb4a404e4de7463af49a08d52d9cc95c%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636465073805310414&sdata=dEqMF6Sr9FqOaPWAwkH%2Bi8LklAv05JeQnr6pMip7l84%3D&reserved=0>

I can connect with the developers through a support incident if necessary.



https://blogs.msdn.microsoft.com/matthew_van_eerde/2016/09/26/report-problems-with-logs-and-suggest-features-with-the-feedback-hub/<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fblogs.msdn.microsoft.com%2Fmatthew_van_eerde%2F2016%2F09%2F26%2Freport-problems-with-logs-and-suggest-features-with-the-feedback-hub%2F&data=02%7C01%7CMatthew.van.Eerde%40microsoft.com%7Ceb4a404e4de7463af49a08d52d9cc95c%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636465073805310414&sdata=Wgba8oVtDQDgYXS4BZshaN99fF%2F%2BtQPxqSzp9sk%2Bw%2Bo%3D&reserved=0>


From: wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx
<wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx>> on 
behalf of Franz Detro 
<franz.detro@xxxxxxxxxxxxxxxxxxxxx<mailto:franz.detro@xxxxxxxxxxxxxxxxxxxxx>>
Sent: Thursday, November 9, 2017 3:25:54 AM
To: wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] Re: USB Audio Class 2 driver and MIDI


Can you go into Device Manager, view by container, expand the peripheral in 
question, and send a screenshot?

here we go:

<TKS4m2.png>


iAP Interface is not bound to a driver (iOS only), the other interface with 
exclamation mark is the DFU interface (no matching driver installed).


<TKS4m2-uac2.png>





From: wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx
<wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx>> on 
behalf of Franz Detro 
<franz.detro@xxxxxxxxxxxxxxxxxxxxx<mailto:franz.detro@xxxxxxxxxxxxxxxxxxxxx>>
Sent: Wednesday, November 8, 2017 7:28:00 AM
To: wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] USB Audio Class 2 driver and MIDI

Hi there!

I have issues with MIDI ports not being available in the system when the 
Microsoft Windows 10 UAC2 driver is loaded (latest version 10.0.17025.1000 from 
Windows 10 Insider Preview Build 17025.rs_prerelease.171020-1626).

Microsoft documentation at

https://docs.microsoft.com/en-us/windows-hardware/drivers/audio/usb-2-0-audio-drivers<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows-hardware%2Fdrivers%2Faudio%2Fusb-2-0-audio-drivers&data=02%7C01%7CMatthew.van.Eerde%40microsoft.com%7C83fb5df2bdfc4424cc5d08d526bd6ac9%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636457517369882738&sdata=1oAPQ1v8OAIut5WqHHy0jp2Av9cU%2BMppG%2FTjEPSmTd4%3D&reserved=0>

claims that the USB Audio Class 1 driver should be loaded for the MIDI 
interface / function:



USB Audio 2.0 Devices with MIDI (subclass 0x03 above) will enumerate the MIDI 
function as a separate multi-function device with usbaudio.sys (USB Audio 1.0 
driver) loaded.

Does this work for somebody on this list?

Franz



PNG image

Other related posts: