[wdmaudiodev] Re: Touble with Vista Treble & Bass control

  • From: Ernest_Burghardt@xxxxxxxxxxxx
  • To: wdmaudiodev@xxxxxxxxxxxxx
  • Date: Tue, 17 Jul 2007 11:22:13 -0700

Hi DJ,

We are the system default for playback and do have a HID interface
implemented, which works as expected in XP...  We are sending HID Consumer
Controls from the satelite, is this handled differently in Vista?
With all of those areas covered, if this is not an enumeration issue, what
else could cause this behaviour?

Thanks


Ernest L. Burghardt
Software Engineer
Logitech
360-256-3239 (office)


                                                                           
                                                                           
                                                                           
             DJ Sisolak                                                 To 
             <dsisolak@exchang         "wdmaudiodev@xxxxxxxxxxxxx"         
             e.microsoft.com>          <wdmaudiodev@xxxxxxxxxxxxx>         
                                                                        cc 
             Sent by:                                                      
             wdmaudiodev-bounc                                     Subject 
             e@xxxxxxxxxxxxx           [wdmaudiodev] Re: Touble with Vista 
                                       Treble & Bass control               
                                                                           
             07/17/2007 10:19                                              
             AM                                                            
                                                                           
                                                                           
             Please respond to                                             
             wdmaudiodev@freel                                             
                 ists.org                                                  
                                                                           
                                                                           




Hi Ernest,

If you can adjust the controls from the control panel then the device's
audio interfaces have enumerated correctly. To get the Treble and Bass
controls sent from the device you need to implement the associated HID
controls. Also, for HID controls to work, the device must be selected as
the preferred audio device in the system.

Do you have a HID interface implemented? Is your device the preferred
device?

Cheers,
DJ Sisolak
Microsoft Corp.

-----Original Message-----
From: wdmaudiodev-bounce@xxxxxxxxxxxxx
[mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx] On Behalf Of
Ernest_Burghardt@xxxxxxxxxxxx
Sent: Tuesday, July 17, 2007 9:22 AM
To: wdmaudiodev@xxxxxxxxxxxxx
Subject: [wdmaudiodev] Touble with Vista Treble & Bass control



We have a speaker system that is using the in-box usbaudio driver where the
satelites have Treble & Bass controls.
 The satelite responds correctly if the tone is changed from the Vista
control panel, but not from the satelite.
The thought is that our FW is not enumerating the device correctly to
Vista; does that seem reasonable or is there some other possibility?
Also, does anyone know if there is a specific portion of the enumeration
that lets Vista know a device wishes to control Treble & Bass?

Thanks in advance,
Ernie


Ernest L. Burghardt
Software Engineer
Logitech
******************

WDMAUDIODEV addresses:
Post message: mailto:wdmaudiodev@xxxxxxxxxxxxx
Subscribe:    mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=subscribe
Unsubscribe:  mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=unsubscribe
Moderator:    mailto:wdmaudiodev-moderators@xxxxxxxxxxxxx

URL to WDMAUDIODEV page:
http://www.wdmaudiodev.com/

******************

WDMAUDIODEV addresses:
Post message: mailto:wdmaudiodev@xxxxxxxxxxxxx
Subscribe:    mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=subscribe
Unsubscribe:  mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=unsubscribe
Moderator:    mailto:wdmaudiodev-moderators@xxxxxxxxxxxxx

URL to WDMAUDIODEV page:
http://www.wdmaudiodev.com/


******************

WDMAUDIODEV addresses:
Post message: mailto:wdmaudiodev@xxxxxxxxxxxxx
Subscribe:    mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=subscribe
Unsubscribe:  mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=unsubscribe
Moderator:    mailto:wdmaudiodev-moderators@xxxxxxxxxxxxx

URL to WDMAUDIODEV page:
http://www.wdmaudiodev.com/

Other related posts: