[wdmaudiodev] Re: Simple loopback audio driver

  • From: Matthew van Eerde <Matthew.van.Eerde@xxxxxxxxxxxxx>
  • To: Олег Герасимчук <supportaview@xxxxxxxxx>, "wdmaudiodev@xxxxxxxxxxxxx" <wdmaudiodev@xxxxxxxxxxxxx>
  • Date: Tue, 8 Mar 2016 21:05:23 +0000

Check out PKEY_AudioDevice_NeverSetAsDefaultEndpoint

https://msdn.microsoft.com/en-us/library/windows/hardware/ff537750(v=vs.85).aspx

From: Олег Герасимчук<mailto:supportaview@xxxxxxxxx>
Sent: Tuesday, March 8, 2016 12:08 PM
To: wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] Re: Simple loopback audio driver

And installed default audio drivers by the system. And there are no other 
custom drivers installed.


2016-03-08 21:37 GMT+02:00 Tim Roberts <timr@xxxxxxxxx<mailto:timr@xxxxxxxxx>>:
Олег Герасимчук wrote:


Thank you you so much! You helped me a lot! Now I will test a driver.

And one more thing: After installing my driver on "fresh" Windows it's
selected as default by system. Is there a way to prevent this?

Did that system have an audio device?  If you are the only audio driver,
then of course you will be the default.

--
Tim Roberts, timr@xxxxxxxxx<mailto:timr@xxxxxxxxx>
Providenza & Boekelheide, Inc.

******************

WDMAUDIODEV addresses:
Post message: mailto:wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Subscribe:    
mailto:wdmaudiodev-request@xxxxxxxxxxxxx<mailto:wdmaudiodev-request@xxxxxxxxxxxxx>?subject=subscribe
Unsubscribe:  
mailto:wdmaudiodev-request@xxxxxxxxxxxxx<mailto:wdmaudiodev-request@xxxxxxxxxxxxx>?subject=unsubscribe
Moderator:    
mailto:wdmaudiodev-moderators@xxxxxxxxxxxxx<mailto:wdmaudiodev-moderators@xxxxxxxxxxxxx>

URL to WDMAUDIODEV page:
http://www.wdmaudiodev.com/


Other related posts: