[wdmaudiodev] Re: Qusetion about IAudioSessionControl / ISimpleAudioVolume

  • From: "Vincent Burel \(VB-Audio\)" <vincent.burel@xxxxxxxxxxxx>
  • To: <wdmaudiodev@xxxxxxxxxxxxx>
  • Date: Mon, 15 Oct 2018 20:51:44 +0200

Bingo! « Feedback Hub » again ! 

 

 

De : wdmaudiodev-bounce@xxxxxxxxxxxxx
[mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx] De la part de Matthew van Eerde
(Redacted sender "Matthew.van.Eerde" for DMARC)
Envoyé : lundi 15 octobre 2018 20:13
À : wdmaudiodev@xxxxxxxxxxxxx
Objet : [wdmaudiodev] Re: Qusetion about IAudioSessionControl /
ISimpleAudioVolume

 

Sounds like a bug. Please file it in Feedback Hub. Include logs of the
problem in action.

 

  _____  

From: wdmaudiodev-bounce@xxxxxxxxxxxxx <wdmaudiodev-bounce@xxxxxxxxxxxxx> on
behalf of Vincent Burel (VB-Audio) <vincent.burel@xxxxxxxxxxxx>
Sent: Monday, October 15, 2018 9:37:07 AM
To: wdmaudiodev@xxxxxxxxxxxxx
Subject: [wdmaudiodev] Qusetion about IAudioSessionControl /
ISimpleAudioVolume 

 

No luck so…

 

Just tried to post it on the social forum you pointed , and it says :

·         Body text cannot contain images or links until we are able to
verify your account.

 

Just paid 1000$ this week to renew my Visual Studio subscription, and what ?
they cannot verify my account !? :-) but they can take money!

 

Here it is my question: 

TITLE: IAudioSessionControl / ISimpleAudioVolume->SetMasterVolume does not
work with Windows Media Player

 

QUESTION: In our new Voicemeeter Virtual Audio Mixer Application, we use
IAudioSessionManager2 to enumerate audio sessions on our Virtual Audio Input
and we use ISimpleAudioVolume->SetMasterVolume to change the volume of a
given application... It works with all applications except with Windows
Media Player (WIN7 or WIN10).

When changing the volume on Windows Media Player, it changes on Windows
Volume Mixer and Voicemeeter.

When changing the volume on Windows Mixer , it changes the volume on Windows
Media Player and Voicemeeter.

When changing the volume on Voicemeeter, it changes the volume on Windows
Mixer, but not on Windows Media Player.

Why?

 

SessionControlISimpleAudioVolume.jpg

 

 

 

De : wdmaudiodev-bounce@xxxxxxxxxxxxx
[mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx] De la part de Matthew van Eerde
(Redacted sender "Matthew.van.Eerde" for DMARC)
Envoyé : lundi 15 octobre 2018 17:27
À : wdmaudiodev@xxxxxxxxxxxxx
Objet : [wdmaudiodev] Re: virtual audio driver removed via devcon, but it's
only hidden

 

*       The feedback hub is useless if there is no-one to read it and check
the problem and correct it

 

Sure. Luckily, there *are* people to read it and check the problem and
correct it.

 

You can post questions about Windows audio APIs to the Windows Desktop
Pro-Audio Application Development forum

https://social.msdn.microsoft.com/Forums/en-US/home?forum=windowspro-audiode
velopment
<https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fsocial.msd
n.microsoft.com%2FForums%2Fen-US%2Fhome%3Fforum%3Dwindowspro-audiodevelopmen
t%26filter%3Dalltypes%26sort%3Dlastpostdesc&data=02%7C01%7CMatthew.van.Eerde
%40microsoft.com%7Ca5af0504f11844ce8d4308d632bc8474%7C72f988bf86f141af91ab2d
7cd011db47%7C1%7C0%7C636752182639188007&sdata=IlVc9h3BZGjD%2FvGxk9GFB3gi%2BC
M%2BqREZGQGncOubnZE%3D&reserved=0> &filter=alltypes&sort=lastpostdesc

 

From: Vincent Burel (VB-Audio) <mailto:vincent.burel@xxxxxxxxxxxx
Sent: Monday, October 15, 2018 12:13 AM
To: wdmaudiodev@xxxxxxxxxxxxx
Subject: [wdmaudiodev] Re: virtual audio driver removed via devcon, but it's
only hidden

 

Well, we are talking about bugs that are present since years,

And some are there since WIN7 (I even talked about WASAPI bugs on this list
that are present since VISTA)

So no, you cannot say that your company cares about Audio. 

 

I thank you for your personal effort, but as I already suggested, the
feedback hub is useless if there is no-one to read it and check the problem
and correct it. 

It’s like the story about HLK certification, it’s just showing the
way…Microsoft build an audio driver official example, Microsoft build a
certification process, mandatory to sign this driver, and no-one at
Microsoft is checking that SYSVAD is passing the HLK tests !?! Madness ? 

 

Anyway I’ve played recently with IAudioSessionManager2, IAudioSessionControl
etc… and I have 2 or 3 questions about this (totally bugged btw).

Since I saw you have GitHub for an example of code on these interfaces, let
me know where do you prefer I put my questions ? 

 

Regards

Vincent Burel

 

 

De : wdmaudiodev-bounce@xxxxxxxxxxxxx
[mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx] De la part de Matthew van Eerde
(Redacted sender "Matthew.van.Eerde" for DMARC)
Envoyé : samedi 13 octobre 2018 13:13
À : wdmaudiodev@xxxxxxxxxxxxx
Objet : [wdmaudiodev] Re: virtual audio driver removed via devcon, but it's
only hidden

 

*       Microsoft does not care about this

 

Yes we do

 

*       Please post a request in Feedback Hub

 

We say this because we want the log files so we can see what happened

 



From: wdmaudiodev-bounce@xxxxxxxxxxxxx <wdmaudiodev-bounce@xxxxxxxxxxxxx> on
behalf of Vincent Burel (VB-Audio) <vincent.burel@xxxxxxxxxxxx>
Sent: Saturday, October 13, 2018 12:14:52 AM
To: wdmaudiodev@xxxxxxxxxxxxx
Subject: [wdmaudiodev] Re: virtual audio driver removed via devcon, but it's
only hidden 

 

Hello,

 

The problem is there since WIN7 and it seems the reboot is finalizing the
uninstallation (this is the only way we found to be sure about the audio
driver de-installation) .

…with WIN10 there is additional problems regarding driver
installation/de-installation, especially re-installation (used by WIN10
automatic update).

 

Also devcon.exe seems to be bugged and can install 2 instances of your audio
driver, the instance will be marked as disabled, but de-installation won’t
be clear anyway if you don’t de-install manually the disabled occurrence of
your driver…

 

Microsoft does not care about this and the only reply will get is “please
post a request in feedback hub”

 

Regards

Vincent Burel

 

De : wdmaudiodev-bounce@xxxxxxxxxxxxx
[mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx] De la part de Johannes Freyberger
Envoyé : samedi 13 octobre 2018 08:37
À : wdmaudiodev@xxxxxxxxxxxxx
Objet : [wdmaudiodev] virtual audio driver removed via devcon, but it's only
hidden

 

Hi all,

 

when I’m uninstalling my pure virtual audio driver on some W10, 1803
machines via devcon remove the driver the driver doesn’t seem to be
uninstalled completely as it is still visible as hidden device in the device
manager even after a reboot. But in setupapi.dev.log the corresponding entry
says:

 

 [Delete Device - ROOT\MEDIA\0006]

 Section start 2018/10/12 09:52:11.354

      cmd: "C:\Program Files (x86)\MyApplication\devcon.exe" remove
*MyDriver

     dvi: Query-and-Remove succeeded

<<<  Section end 2018/10/12 09:52:12.031

<<<  [Exit status: SUCCESS]

 

On some other machines the drivers are completely gone and not in hidden
state.

 

Could this “hidden driver” effect be due to user privileges or some Antivir
software installed on these machines? 

What makes an uninstalled driver go into this hidden state and can this have
any subsequent negative effects if I’m installing a new version of my driver
while the old version is still in this hidden state? 

Could this be something which is new since the 1803 update as I don’t think
I’ve seen this before?

 

Thanks and best regards,

Johannes Freyberger

 

 

JPEG image

PNG image

Other related posts: