[wdmaudiodev] Re: MFX APO on 7.1 endpoint

  • From: "Matthew van Eerde" <dmarc-noreply@xxxxxxxxxxxxx> (Redacted sender "Matthew.van.Eerde" for DMARC)
  • To: "wdmaudiodev@xxxxxxxxxxxxx" <wdmaudiodev@xxxxxxxxxxxxx>
  • Date: Tue, 26 Mar 2019 16:15:50 +0000

Another common error is to register the MFX CLSID, but not the “supported for 
streaming” property.

________________________________
From: wdmaudiodev-bounce@xxxxxxxxxxxxx <wdmaudiodev-bounce@xxxxxxxxxxxxx> on 
behalf of Matthew van Eerde <dmarc-noreply@xxxxxxxxxxxxx>
Sent: Tuesday, March 26, 2019 9:12:23 AM
To: wdmaudiodev@xxxxxxxxxxxxx
Subject: [wdmaudiodev] Re: MFX APO on 7.1 endpoint

It is a driver authoring error to attempt to expose SFX/MFX/EFX on an interface 
that does not support the signal processing modes. Running the HLK tests should 
help you pinpoint your error.

________________________________
From: wdmaudiodev-bounce@xxxxxxxxxxxxx <wdmaudiodev-bounce@xxxxxxxxxxxxx> on 
behalf of Michael Johansen <johansen.mic@xxxxxxxxx>
Sent: Tuesday, March 26, 2019 9:10:16 AM
To: wdmaudiodev@xxxxxxxxxxxxx
Subject: [wdmaudiodev] Re: MFX APO on 7.1 endpoint

Well that was actually the problem. First I registered the APO as an MFX in the 
INF. No luck. Then SFX. No luck. Then EFX. No luck.
Then as LFX and then it was loaded. This was on Windows 10. That is why I am 
trying to understand what in the binary is causing Windows 10 to choose the way 
it does.

Michael

Den tir. 26. mar. 2019 kl. 17.06 skrev Matthew van Eerde 
<dmarc-noreply@xxxxxxxxxxxxx<mailto:dmarc-noreply@xxxxxxxxxxxxx>>:
If a driver has any of the (SFX, MFX, EFX) CLSIDs registered in the FX property 
store, then Windows 10 will use them.

If it has none of the three, Windows 10 will look for (LFX, GFX) CLSIDs and use 
them if they are present.

If none of the five are present, then there just won’t be any APOs.

I don’t know the answer to your HCK question.

________________________________
From: wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx
<wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx>> on 
behalf of Michael Johansen 
<johansen.mic@xxxxxxxxx<mailto:johansen.mic@xxxxxxxxx>>
Sent: Tuesday, March 26, 2019 9:00:56 AM
To: wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] Re: MFX APO on 7.1 endpoint

OK. The documentation is not very clear on what determines that. Implementation 
of IMiniportAudioSignalProcessing?

Another short question: is it still possible to run HCK testing and submissions 
for Windows 7 and 8.1 or should I just forget about it?

Regards,

Michael

Den tir. 26. mar. 2019 kl. 15.51 skrev Matthew van Eerde 
<dmarc-noreply@xxxxxxxxxxxxx<mailto:dmarc-noreply@xxxxxxxxxxxxx>>:
Windows 7 only supports LFX and GFX.

Windows 10 supports SFX, MFX, and EFX. If a driver reports both (LFX, GFX) and 
(SFX, MFX, EFX) then Windows 10 will prefer (SFX, MFX, EFX.)

For compatibility reasons, if a driver reports only (LFX, GFX), Windows 10 will 
work with it.

________________________________
From: wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx
<wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx>> on 
behalf of Michael Johansen 
<johansen.mic@xxxxxxxxx<mailto:johansen.mic@xxxxxxxxx>>
Sent: Tuesday, March 26, 2019 4:58:17 AM
To: wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] Re: MFX APO on 7.1 endpoint

Thanks Matthew.

It turns out that if I attach the APO as an LFX (on windows 10) it works.
The driver is a WinRT driver but built for compatibility with Windows 7.

I was under the impression that SFX, MFX and EFX are the only APOs available in 
Windows 10 and not LFX and GFX.
Do you know that properties of the driver determines this?

Michael

Den man. 25. mar. 2019 kl. 22.06 skrev Matthew van Eerde 
<dmarc-noreply@xxxxxxxxxxxxx<mailto:dmarc-noreply@xxxxxxxxxxxxx>>:
No, it should just work.

________________________________
From: wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx
<wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx>> on 
behalf of Michael Johansen 
<johansen.mic@xxxxxxxxx<mailto:johansen.mic@xxxxxxxxx>>
Sent: Monday, March 25, 2019 9:15:16 AM
To: wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] MFX APO on 7.1 endpoint

I am working on a PortCls driver for a 7.1 audio device. We have an existing 
working APO that we have modified to support 7.1 audio. I am registering the 
APO via the driver INF - business as usual - but it never gets loaded when 
playing audio.

Any special registration required for this type of endpoint?

Best regards,

Michael

Other related posts: