[wdmaudiodev] Re: MFX APO on 7.1 endpoint

  • From: Michael Johansen <johansen.mic@xxxxxxxxx>
  • To: wdmaudiodev@xxxxxxxxxxxxx
  • Date: Tue, 26 Mar 2019 17:00:56 +0100

OK. The documentation is not very clear on what determines that.
Implementation of IMiniportAudioSignalProcessing?

Another short question: is it still possible to run HCK testing and
submissions for Windows 7 and 8.1 or should I just forget about it?

Regards,

Michael

Den tir. 26. mar. 2019 kl. 15.51 skrev Matthew van Eerde <
dmarc-noreply@xxxxxxxxxxxxx>:

Windows 7 only supports LFX and GFX.



Windows 10 supports SFX, MFX, and EFX. If a driver reports both (LFX, GFX)
and (SFX, MFX, EFX) then Windows 10 will prefer (SFX, MFX, EFX.)



For compatibility reasons, if a driver reports only (LFX, GFX), Windows 10
will work with it.


------------------------------
*From:* wdmaudiodev-bounce@xxxxxxxxxxxxx <wdmaudiodev-bounce@xxxxxxxxxxxxx>
on behalf of Michael Johansen <johansen.mic@xxxxxxxxx>
*Sent:* Tuesday, March 26, 2019 4:58:17 AM
*To:* wdmaudiodev@xxxxxxxxxxxxx
*Subject:* [wdmaudiodev] Re: MFX APO on 7.1 endpoint

Thanks Matthew.

It turns out that if I attach the APO as an LFX (on windows 10) it works.
The driver is a WinRT driver but built for compatibility with Windows 7.

I was under the impression that SFX, MFX and EFX are the only APOs
available in Windows 10 and not LFX and GFX.
Do you know that properties of the driver determines this?

Michael

Den man. 25. mar. 2019 kl. 22.06 skrev Matthew van Eerde <
dmarc-noreply@xxxxxxxxxxxxx>:

No, it should just work.


------------------------------
*From:* wdmaudiodev-bounce@xxxxxxxxxxxxx <
wdmaudiodev-bounce@xxxxxxxxxxxxx> on behalf of Michael Johansen <
johansen.mic@xxxxxxxxx>
*Sent:* Monday, March 25, 2019 9:15:16 AM
*To:* wdmaudiodev@xxxxxxxxxxxxx
*Subject:* [wdmaudiodev] MFX APO on 7.1 endpoint

I am working on a PortCls driver for a 7.1 audio device. We have an
existing working APO that we have modified to support 7.1 audio. I am
registering the APO via the driver INF - business as usual - but it never
gets loaded when playing audio.

Any special registration required for this type of endpoint?

Best regards,

Michael


Other related posts: