[wdmaudiodev] Re: HLK test error

  • From: Martin Ordell Sørensen <odl@xxxxxxxxxxx>
  • To: "wdmaudiodev@xxxxxxxxxxxxx" <wdmaudiodev@xxxxxxxxxxxxx>
  • Date: Wed, 31 Oct 2018 07:37:24 +0000

Hi,

I cannot say for sure but since it looks to be an exception in vrfcore.dll, I'm 
not sure how the APO would cause this.

Anyway, I just made it pass the test by rebooting both the controller and the 
client and rerunning the test. So while I am able to pass all tests now, I am 
still not much wiser in regards to what caused the problem in the first place, 
so I worry that this issue will pop up again another time.

Best regards, Martin

From: wdmaudiodev-bounce@xxxxxxxxxxxxx <wdmaudiodev-bounce@xxxxxxxxxxxxx> On 
Behalf Of Matthew van Eerde
Sent: 30. oktober 2018 16:43
To: wdmaudiodev@xxxxxxxxxxxxx
Subject: [wdmaudiodev] Re: HLK test error

Why do you say it is related to the tool and not the APO?

________________________________
From: wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx
<wdmaudiodev-bounce@xxxxxxxxxxxxx<mailto:wdmaudiodev-bounce@xxxxxxxxxxxxx>> on 
behalf of Martin Ordell Sørensen <odl@xxxxxxxxxxx<mailto:odl@xxxxxxxxxxx>>
Sent: Tuesday, October 30, 2018 2:27:48 AM
To: wdmaudiodev@xxxxxxxxxxxxx<mailto:wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] HLK test error

Hi,

I am trying to pass RS5 HLK tests on an audio codec but one of the tests is 
failing and I am not sure what I can do about it. It looks to me to be related 
to the tool and not the driver/APO.

The controller is a fully updated Windows Server 2016 build 14393 with latest 
HLK Studio (10.1.17763.1) and the client is running Windows 10 build 17763. I 
have applied the latest (as of yesterday) .sql update to the database.
The error I am getting is this:

A crash with exception code 0x80000003 occurred in module "vrfcore.dll" in 
process "te.processhost.exe" (pid:7436).
WexTraceInfo ThreadId=1724 ProcessId=6560 TimeStamp=1651200919 LogSessionId=0
WexContext TAEF
AppCrashEvent ReportId=281b1a35-6d57-44a8-9cb0-2249a32dfa54

[HRESULT 0x800706BE] A failure occurred while running a test operation: 
'CApoDeviceTests::TestValidFrameCount'. (A crash with exception code 0x80000003 
occurred in module "vrfcore.dll" in the process hosting the test code while 
invoking a test operation.)
WexTraceInfo ThreadId=7440 ProcessId=6560 TimeStamp=1666616608 LogSessionId=1
WexContext TAEF
AppCrashEvent ReportId=281b1a35-6d57-44a8-9cb0-2249a32dfa54

Is this a known issue and is there anything I can do about it?
All other tests are passing so I am just missing this one.

Best regards, Martin

Other related posts: