[wdmaudiodev] Re: HLK failed due to crash of the HLK program

  • From: "Matthew van Eerde" <dmarc-noreply@xxxxxxxxxxxxx> (Redacted sender "Matthew.van.Eerde" for DMARC)
  • To: "wdmaudiodev@xxxxxxxxxxxxx" <wdmaudiodev@xxxxxxxxxxxxx>
  • Date: Wed, 10 Jul 2019 15:51:42 +0000

Run !analyze -v and share the output.
Better yet, get permission, and share the dump file itself.


  *   Is there a Microsoft email we can send to

You can open a support case if you want private help.

________________________________
From: wdmaudiodev-bounce@xxxxxxxxxxxxx <wdmaudiodev-bounce@xxxxxxxxxxxxx> on 
behalf of Vincent Wang <vincent0wang@xxxxxxxxxxx>
Sent: Tuesday, July 9, 2019 10:33:42 PM
To: wdmaudiodev@xxxxxxxxxxxxx <wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] Re: HLK failed due to crash of the HLK program

Hi Matthew,

Thanks for the reply.
We collected the crash dump and it is still not clear what caused the crash.

Another find, the crash always happen regardless whether our APO is engaged.
However, the crash happens earlier when APO is engaged and the following test 
cannot continue and marked as fail.
When APO is not engaged, the crash happens but after the test case marked as 
success.

How can we provide you the crash dump? Is there a Microsoft email we can send 
to?
There are our APO and another partner APO involved, I can not attach here 
without their permission.

Best Regards
Vincent
________________________________
From: wdmaudiodev-bounce@xxxxxxxxxxxxx <wdmaudiodev-bounce@xxxxxxxxxxxxx> on 
behalf of Matthew van Eerde <dmarc-noreply@xxxxxxxxxxxxx>
Sent: Tuesday, July 9, 2019 11:58 PM
To: wdmaudiodev@xxxxxxxxxxxxx
Subject: [wdmaudiodev] Re: HLK failed due to crash of the HLK program


Ah, here we go – set up a postmortem debugger. That will let you catch and 
debug the crash “in the moment.”



https://docs.microsoft.com/en-us/windows-hardware/drivers/debugger/enabling-postmortem-debugging<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fwindows-hardware%2Fdrivers%2Fdebugger%2Fenabling-postmortem-debugging&data=02%7C01%7Cmatthew.van.eerde%40microsoft.com%7C78ec1a87a2624f32d94e08d704f84277%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636983336725229421&sdata=g%2FC9w6ftO0o0TrP0sKJe7DmtUb0w7x7LJNuu42xFKlk%3D&reserved=0>



________________________________
From: wdmaudiodev-bounce@xxxxxxxxxxxxx <wdmaudiodev-bounce@xxxxxxxxxxxxx> on 
behalf of Matthew van Eerde <dmarc-noreply@xxxxxxxxxxxxx>
Sent: Tuesday, July 9, 2019 8:28:01 AM
To: wdmaudiodev@xxxxxxxxxxxxx <wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] Re: HLK failed due to crash of the HLK program


From the description it sounds like Application Verifier caught a problem. It’s 
not clear to me from the error message whether the problem is in your APO, or 
the test, or in Windows. There should be a way to find the corresponding 
te.processhost.dmp file which should shed light on the matter.



________________________________
From: wdmaudiodev-bounce@xxxxxxxxxxxxx <wdmaudiodev-bounce@xxxxxxxxxxxxx> on 
behalf of Vincent Wang <vincent0wang@xxxxxxxxxxx>
Sent: Monday, July 8, 2019 11:59:48 PM
To: wdmaudiodev@xxxxxxxxxxxxx <wdmaudiodev@xxxxxxxxxxxxx>
Subject: [wdmaudiodev] HLK failed due to crash of the HLK program

Hi Matthew,

We're facing the same issue as reported in below post.
Using HLK 18362, re-installed OS/HLK software on client, same crash.
No issue when running RS5.
Is this a bug in the 19H1 HLK test kit?

Best REgards
Vincent

https://social.msdn.microsoft.com/Forums/en-US/654e30f8-e2ed-41a0-8a67-85d819f97526/a-crash-with-exception-code-0x80000003-occurred-in-module-quotvrfcoredllquot?forum=whck<https://nam06.safelinks.protection.outlook.com/?url=https%3A%2F%2Fsocial.msdn.microsoft.com%2FForums%2Fen-US%2F654e30f8-e2ed-41a0-8a67-85d819f97526%2Fa-crash-with-exception-code-0x80000003-occurred-in-module-quotvrfcoredllquot%3Fforum%3Dwhck&data=02%7C01%7Cmatthew.van.eerde%40microsoft.com%7C78ec1a87a2624f32d94e08d704f84277%7C72f988bf86f141af91ab2d7cd011db47%7C1%7C0%7C636983336725239420&sdata=vu6Gl3GbcBmXZ1ytwh7kY0aCa8cijaYkK3mZhUvzang%3D&reserved=0>


A crash with exception code 0x80000003 occurred in module "vrfcore.dll" in 
process "te.processhost.exe"

Message:
 WexTraceInfo ThreadId=5852 ProcessId=4884 TimeStamp=1074741179 LogSessionId=0
 WexContext TAEF
 AppCrashEvent ReportId=96c941e4-f711-4147-8883-a0b952a5d7ef

Error:
[HRESULT 0x800706BE] A failure occurred while running a test operation: 
'CApoDeviceTests::TestCustomFormatSupport'.
(A crash with exception code 0x80000003 occurred in module "vrfcore.dll" in the 
process hosting the test code while invoking a test operation.)
AppCrashEvent ReportId=96c941e4-f711-4147-8883-a0b952a5d7efT

Try to delect vrfcore.dll on the registry entry for your application and try to 
run, still fail

Other related posts: