[wdmaudiodev] Re: DTM Test on USBAUDIO.SYS with a custom INF, with Windows 8

  • From: "M'hand Boughias" <mhand@xxxxxxxxxxxxx>
  • To: wdmaudiodev@xxxxxxxxxxxxx
  • Date: Wed, 5 Jun 2013 22:18:34 +0200

I will try this, thank you for the tip.
Regards,
M'hand Boughias


On Wed, Jun 5, 2013 at 7:29 PM, Matthew van Eerde <
Matthew.van.Eerde@xxxxxxxxxxxxx> wrote:

>  In your submission readme.txt, cite errata 511 for this failure, which
> will prompt a manual review of the submission. This looks like test bug
> Windows Blue Bugs 17160 to me.****
>
> ** **
>
> *From:* wdmaudiodev-bounce@xxxxxxxxxxxxx [mailto:
> wdmaudiodev-bounce@xxxxxxxxxxxxx] *On Behalf Of *M'hand Boughias
> *Sent:* Wednesday, June 5, 2013 10:11 AM
> *To:* wdmaudiodev@xxxxxxxxxxxxx
> *Subject:* [wdmaudiodev] DTM Test on USBAUDIO.SYS with a custom INF, with
> Windows 8****
>
> ** **
>
> Hi, ****
>
> I am trying to pass the DTM audio test on an USBAUDIO device with a custom
> INF.****
>
> My custom INF :****
>
>  - Includes wdma_usb.inf****
>
>  - Calls the USBAudio sections to install the usbaudio driver ****
>
>  - Add a custom LFX APO dll****
>
>  ****
>
> It seems that WaveTest.exe does not recognize my driver as usbaudio.sys
> and try to pass this test : *Reset Pin while streaming data. *This test
> fails because USBAUDIO.SYS is not a port class driver and does not support
> the *IOCTL_KS_RESET_STATE *request.****
>
> WaveTest output : ****
>
>  *FAIL: Pin has not responded to IOCTL_KS_RESET_STATE command for
> KSRESET_BEGIN correctly. Position after reset is not zero*****
>
>  When I start the same test with the standard wdma_usb.inf installation,
> WaveTest write:****
>
>  *The driver used is a known non-portcls driver: wdma_usb.inf*.****
>
> ...****
>
> *IOCTL_KS_RESET_STATE is not required to be supported by non-portcls
> drivers*****
>
>  And the test is skipped.****
>
>  ****
>
> I tried to apply the DTM Filters, there is a DTM filter related to this
> issue (ID:511, *
> https://sysdev.microsoft.com/fr-FR/Hardware/EC/FilterDetail.aspx?id=271*) but
> it is only for the capture pin, not for the render pin. ****
>
> Have you any idea how to pass this test with a custom INF?****
>
>  ****
>
> Regards,****
>
>  ****
>
> M'hand BOUGHIAS****
>
>  ****
>
>  ****
>
>  ****
>

Other related posts: