[wdmaudiodev] Re: Audio OUT on Longhorn

  • From: Matt Gonzalez <matt@xxxxxxxxxxxxx>
  • To: wdmaudiodev@xxxxxxxxxxxxx
  • Date: Fri, 15 Jul 2005 12:08:44 -0700

Hello Hakon-

Could you please clarify something? You state that only portcls.sys and the miniport driver are left in the kernel for Longhorn. What about AVStream support - doesn't that require ks.sys?

The reason I ask is that the audio driver for our 1394 hardware is based on the AVStream model.

Matt

Hakon Strande wrote:

Dear Sir,

The Windows Audio system has been completely re-designed for Longhorn to
better enable high fidelity, transparency, stability, glitch resilience
and low latency. All audio kernel components (like the well-known
kmixer.sys and sysaudio.sys, etc) are gone and the functionality moved
to user mode, the only components left in the kernel is the audio helper
library PortCls.sys and the miniport driver itself.


This may be the cause of your problem depending on what you mean by "AVS
WDM". Longhorn audio system documentation will most likely be available
sometime during the Beta 2 time frame but compatibility goal with legacy
drivers is 100% so if you have issues please file bugs through the beta
program.



******************

WDMAUDIODEV addresses:
Post message: mailto:wdmaudiodev@xxxxxxxxxxxxx
Subscribe:    mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=subscribe
Unsubscribe:  mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=unsubscribe
Moderator:    mailto:wdmaudiodev-moderators@xxxxxxxxxxxxx

URL to WDMAUDIODEV page:
http://www.wdmaudiodev.com/

Other related posts: