[wdmaudiodev] Re: AVStream Filter Driver

  • From: "Tim Roberts" <timr@xxxxxxxxx>
  • To: "wdmaudiodev" <wdmaudiodev@xxxxxxxxxxxxx>
  • Date: Tue, 25 May 2010 08:22:55 -0700

You wrote:
>
>  I have to write a AVstream filter centric driver which should be
>installed as a ks volumn filter. The filter has two pins-sink and 
>source, and a internal volumn node. I modify the code of avssamp. My
>target is to make such filter graph available:
>  source filter--->volumn filter---->audio render filter(wave out device)
>
>  Using GraphEdit, I can connect a source filter with the volumn filter,
>but failed to connect volumn filter with audio render filter with an
>error 0x80040217. If I directly connect source filter to audio render
>filter, they can connect.
>  I I think my pin descripters are not very right. This is the two pin
>descriptoer i wrote:

I don't see any problems in your pin descriptors, except that you're using the 
name "Capture" for your output pin, but that's a cosmetic issue.

Have you change the registration category?  Avssamp registers itself as a 
capture filter.  You need to be a transform filter.

You are using the same data ranges and intersect handler for both pins, which 
might be OK.  Can you show us the data ranges?  How many of your routines are 
getting called?  Is the intersect handler being called?  Are you sure it's 
returning success to ONE of the ranges?
--
Tim Roberts, timr@xxxxxxxxx
Providenza & Boekelheide, Inc.
******************

WDMAUDIODEV addresses:
Post message: mailto:wdmaudiodev@xxxxxxxxxxxxx
Subscribe:    mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=subscribe
Unsubscribe:  mailto:wdmaudiodev-request@xxxxxxxxxxxxx?subject=unsubscribe
Moderator:    mailto:wdmaudiodev-moderators@xxxxxxxxxxxxx

URL to WDMAUDIODEV page:
http://www.wdmaudiodev.com/

Other related posts: