[uae] Re: E-UAE on amd64 Linux

  • From: Richard Drummond <evilrich@xxxxxxxxxxxxxx>
  • To: uae@xxxxxxxxxxxxx
  • Date: Fri, 1 Apr 2005 13:37:55 -0500

Hi Nicholas

On Wednesday 30 March 2005 08:15 pm, Nicholas Otley wrote:
> I forgot to mention, I've already got Ubuntu's 64bit libSDL packages
> installed via APT, and every 64bit program that needs them works fine.
>  It's just when I try to use e-uae i get a problem.  I thought maybe
> putting the 32bit libs in the same path may help.

Hmmm. I don't know much about Linux on AMD64.

So, you need 32-bit libraries for 32-bit applications? If that is indeed the 
case - and it does make sense - then simply installing a 32-bit libSDL is 
going to be much use for you. You'll need the 32-bit X libraries also. I 
guess that's doable. How about the C library?

What's Ubuntu's policy for running 32-bit apps on a 64-bit machine? It seems 
that they don't have one. ;-)

Unless somebody else here has more of a clue than I about this stuff, then 
probably the best place to ask such questions would be the Ubuntu support 
fora.

Of course, you called always build E-UAE natively for AMD64. But then the JIT 
compiler won't work.

I could try building you a statically linked 32-bit version of E-UAE. That 
might well work on your system.

Cheers,
Rich

Other related posts: