[THIN] Re: offline printers in session

  • From: Jason CitrixADmin <jasoncitrix@xxxxxxxxx>
  • To: thin <thin@xxxxxxxxxxxxx>
  • Date: Tue, 30 Jun 2015 10:27:08 -0400

I have installed the fixes and am getting mixed results. For one user
there has been zero improvement. Another seems to be doing better, but we
had a server with its own issues yesterday and she does not print daily so
the results are currently inconclusive. I admit I am still skeptical about
it being a client hotfix issue since the client PCs are not in our domain
but simply connecting over the internet. and the printers are going offline
on the server not the client side. However at this point I am looking at
every possibility.


On Tue, Jun 23, 2015 at 11:47 AM, Jeremy Saunders <
jeremy@xxxxxxxxxxxxxxxxxxxx> wrote:

Hi Jason,



Of course there are a truckload of hotfixes to install. But this tells me
the Win7 64-bit image doesn’t even have the basic patches that every build
should have. That hotfix, the 3 regression hotfixes, and many other
hotfixes should be the base of any Windows 7 image….full stop! If Microsoft
did a Desktop RAP, this would be highlighted in their report. Consider this
is a “best practice” hotfix. Does the 32-bit image contain that hotfix, or
maybe you need to compare the core printing components between the 32-bit
and 64-bit Win7 images, as per KB2647753. You’re asking for help on many
forums. I’ve given you a starting point that I believe could help you, but
I’m not sure myself because I know little of your environment and it sounds
like it’s quite outdated. Whether you are in control of the image or not
surely you have a test machine, or can get someone who has control to
install the hotfixes on at least one machine and disable the firewall for
testing?



Cheers,

Jeremy



*From:* thin-bounce@xxxxxxxxxxxxx [mailto:thin-bounce@xxxxxxxxxxxxx] *On
Behalf Of *Jason CitrixADmin
*Sent:* Tuesday, 23 June 2015 8:42 PM

*To:* thin
*Subject:* [THIN] Re: offline printers in session



TO install that particular fix, they would have to then install an
additional three fixes to fix regression issues.



That makes me a bit nervous, due to the fact that in many cases these PCs
are not under our direct control. But I will investigate and see what I
can do. Thank you for the information.





On Tue, Jun 23, 2015 at 8:14 AM, Jason CitrixADmin <jasoncitrix@xxxxxxxxx>
wrote:

Jeremy

In many cases I have no control over the client side firewall. I have
also etup a test server and run through multiple different drivers. I do
think it could be a buffer issue as in some cases the clients can do SOME
printing before the printer goes offline, and the amount they can print
varies and has no real pattern I have been able to find (So far).
Additionally it is a very heterogeneous environment but I will check on the
KB you mention as many of them are on WIndows 7x64 client machines.





On Tue, Jun 23, 2015 at 4:50 AM, Jeremy Saunders <
jeremy@xxxxxxxxxxxxxxxxxxxx> wrote:

Hi Jason,



It’s been years since I’ve built/supported a 4.5 environment, but remember
that there were a couple of known issues. You’ve already mentioned that
you’ve disabled bi-directional support and advanced printing options.



Have you completely disabled the firewall on the client and tested? This
will ensure that all communication can flow back and forth. The TCP/IP Port
Monitor typically polls the printer using SNMP. Also check the community
strings on the drivers to ensure they match the printers. If the clients
have the SNMP feature installed, make sure it has a matching community
string. If everything is default, it will use the “public” community string.



Also, maybe the newer 64-bit clients have a newer version of the driver
and there is a compatibility issue with the client mapping.



To me it sounds like the printers buffer (memory) may be filling up, but
the communication is not working, due to firewall, SNMP, routing, etc.



There’s also tons of client side printing hotfixes to assess. I assume
we’re talking about Windows 7 SP1 64-bit here? Do they have KB2775511
installed?



I really have no idea where your problem lies, but this may give you some
other ideas.



Cheers,

Jeremy



*From:* thin-bounce@xxxxxxxxxxxxx [mailto:thin-bounce@xxxxxxxxxxxxx] *On
Behalf Of *Jason CitrixADmin
*Sent:* Friday, 19 June 2015 3:11 AM
*To:* thin
*Subject:* [THIN] Re: offline printers in session



I have been assembling a list of the printers that routinely go into
offline mode on the server.

So far I have the following printers:



HP LaserJet pro 400M401n

Canon MF 8280C UFRII

HP LaserJet P3011/P3015

Brother HL-2230

HP LaserJet P2055

HP Color LaserJet P2605

HP LaserJet 600 m601

HP LaserJet P3011/P3015

Brother HL-2240

In testing I have setup a dedicated server and been Loading teh actual
drivers for those printers on the server and re-directing users to that
server only to test if the drivers are stable, and if there is an
improvement. FOr the most part I haven ot seen ay changes. After a few
print jobs, the printer goes "Offline" on the server and print jobs pile up
never being spooled to the client side. I have turned off Bi-directional
support and Advanced printing options when I can but Again I have not
noticed a difference. This issue has me completely stumped. There has to
be an underlying cause, but I have been unable to find it and am not sure
where to look either right now.





On Wed, Feb 18, 2015 at 10:56 AM, Jason CitrixADmin <jasoncitrix@xxxxxxxxx>
wrote:

I have come across more users that experience this same issue and they are
printing wit the HP laserJet P2035. However I have a large customer base
and this issue seems fairly isolated so I am not sure if being on a 64bit
machine is the only criteria. While it seems top ONLY be happening on 64
bit machines I am wondering if there is an additional component that I have
not found yet.





On Fri, Feb 13, 2015 at 10:55 AM, Jason CitrixADmin <jasoncitrix@xxxxxxxxx>
wrote:

I have done that as well as turn off "bi-directional support" as i have
seen that help as well.

It has become quite frustrating. The primary printer that this started
with was a Canon with the UFR II drivers.



On Fri, Feb 13, 2015 at 10:16 AM, Jan <tinybeetle@xxxxxxxxx> wrote:

Try turning off "Enable advanced printing features" in the desktop printer
preferences. I've found that tends to fix some of the issues.



On Fri, Feb 13, 2015 at 9:47 AM, Jason CitrixADmin <jasoncitrix@xxxxxxxxx>
wrote:

I have run across an odd situation. I believe I have posted on this
before, but have come up with more information about it.



I have several clients that will print from within their session to the
client mapped printers and then the printer will go "Offline" on the
server. On the client machine the printer is fine, but within their
session the printer shows as offline and print jobs queue up. As soon as
the log out and back in they can print again. I have been told that it
only happens if they "print a lot" but I have not been able to find a
threshold for "lot of printing." These clients are using a variety of
printers from HP laserJets to Canon UFRII printers. They had no issues
till they upgraded their machines to 64bit machines. At one location the
users that are running 64bit machines have this issue, but the one person
with a 32 bit machine have no problem. They are running version 13 of the
Web client on the client side, but I have in the course of trouble-shooting
tried everything from version 10.2 to the latest receiver version and saw
no difference. Is there any idea why this would start occurring after the
update to a 64 bit OS on the client side? Additionally in some cases the
users have the Universal driver and in some they are mapped to a LaserJet 4
driver and there is no difference.



Thank you

Jason















Other related posts: