[THIN] Re: Passthru Authentication - still prompting

  • From: "Ron Jameson" <rjameson@xxxxxxxxxxxxx>
  • To: <thin@xxxxxxxxxxxxx>
  • Date: Tue, 22 Feb 2005 17:23:27 -0600

Joe - I am now using the desktop shortcut from the PN,  I still cannot
get the pass thru to work....in the PN Application Set Settings login
tab, if I select pass thru login for local user, it prompts with the PN
login info/pwd/domain when running the app.  When you enter it, it
changes the login info to User-Specific Credentials.  The ICA Settings
show pass thru enabled.

My other problem is trying to work on why the seamless app is
graphically challenged.  Sluggish in seamless mode when I have tried
turning off/on bitmap cache & speedstream.  
 
Ron
 
________________________________

From: thin-bounce@xxxxxxxxxxxxx [mailto:thin-bounce@xxxxxxxxxxxxx] On
Behalf Of Joe Shonk
Sent: Tuesday, February 22, 2005 5:08 PM
To: thin@xxxxxxxxxxxxx
Subject: [THIN] Re: Passthru Authentication - still prompting



Hmm... Not sure why you are creating custom .ica files.  Simply install
the PN Agent Pass-through client (from the MFPS 3.0 install) and use
that instead.   If you insist on using .ica and want Single Sign on, you
will need to add an entry that allow SSO via an ICA File.

 

Joe

 

________________________________

From: thin-bounce@xxxxxxxxxxxxx [mailto:thin-bounce@xxxxxxxxxxxxx] On
Behalf Of Ron Jameson
Sent: Tuesday, February 22, 2005 12:04 PM
To: thin@xxxxxxxxxxxxx
Subject: [THIN] Passthru Authentication - still prompting

 

Something is awry here that I could use help on from the experts.  This
is the first citrix box install - we normally only do TS2000/2003
installs.

 

I have a citrix PS3ent app server publishing 5-10 apps to another TS2003
server where users login to access the rest of the 10+ programs.  I
created the ICA packaged .ica ini file for the app and put that icon on
a users TS session desktop folder - but when they click on it - it
prompts for login to the citrix.  Am I missing an obvious here?  The
farm has pass thru set and I want the login credentials of the users
domain credentials from the TS session to pass to the citrix app server
seamlessly.  

 

Here is some other oddities I could use some clarification on:

 

1) Using the same published app - the ica ini package opens the program
fine (from the TS2003 session) except for the login needed - it appears
on the TS desktop as a program running there.  Users will NEVER know the
difference...they can minimize it, it only has one top window menu bar
etc.  But, I did notice screen graphics a bit draggy as they seem to
gradually appear rather than snap.

 

Does the ICA engine create that much overhead to drag the program pull
down graphics etc vs. using PN to enter?

 

2) If from the users TS session, I go into PN and run the app thru there
- it passes thru fine with no login (once you enter your own login info
in PN), but the published app screen goes full screen with no TS users
desktop.  So, I changed the published app to 1024x768 instead of full
screen, but now it looks like a session inside the TS session rather
than a program.  Program menus & graphics in this method snap like they
should.

 

I am still trying to test this various ways looking for what I need -
which is icons I can put on the TS2003 Sessions of the users (deployed
via the existing login script where program shortcuts are given to the
users), the icon graphic will need to be able to be changed to match the
program (this may rule out the ICA engine ini file), seamless login to
the app with no secondary login prompts, no drag in graphics and the
program cannot have any extra screen menu bars and appear like the
program is running in the TS session.

 

Any advise would be a great help.  Thanks.

 

 

Ron Jameson

Hamlin Technologies

 

 

 

 

Other related posts: