[THIN] KB: CTX107051 - Unable to Connect with ICA After Installing Microsoft Rollup 1 for Windows 2000

  • From: "Jim Kenzig Kenzig.com" <jkenzig@xxxxxxxxx>
  • To: thin@xxxxxxxxxxxxx
  • Date: Fri, 1 Jul 2005 11:04:33 -0700 (PDT)

CTX107051 - Unable to Connect with ICA After Installing Microsoft Rollup 1 for 
Windows 2000 

This document was published at: 
http://support.citrix.com/kb/entry.jspa?externalID=CTX107051 


Document ID: CTX107051, Created on: Jun 30, 2005, Updated: Jul 1, 2005 
Products: Citrix MetaFrame XP 1.0 for Microsoft Windows 2000, Citrix MetaFrame 
Presentation Server 3.0 for Microsoft Windows 2000 
 
Symptoms

Users connecting with ICA sessions receive a blue background and the Windows 
GINA does not display after installing Microsoft Rollup 1 for Windows 2000 SP4 
on Metaframe XP and MPS 3.0 Servers. 

The console might be unresponsive and have high CPU utilization within the 
winlogon.exe process.

Cause

Issue occurs after applying the Microsoft Update Rollup 1 for Windows 2000 SP4 
(KB article ID 891861) to Metaframe XP FR3 Service Pack 4 servers and MPS 3.0 
servers.

Workaround

Citrix recommends the following temporary workaround:

Caution! This fix requires you to edit the registry. Using Registry Editor 
incorrectly can cause serious problems that may require you to reinstall your 
operating system. Citrix cannot guarantee that problems resulting from the 
incorrect use of Registry Editor can be solved. Use Registry Editor at your own 
risk. Be sure to back up the registry before you edit it.

1.) Open Regedt32

2.) Navigate to the following location:


HKLM\Software\Citrix\Ctxhook\AppInit_Dlls\Smart Card Hook

3.) Rename the ?FilePathName? key from ?scardhook.dll? to ?scardhook.dll.old?

4.) Reboot the server




Please Note - If you require smartcard functionality in your environment the 
temporary workaround is to uninstall the Microsoft Update Rollup 1 for Windows 
2000 SP4 (KB article ID 891861).

Status

Citrix is currently investigating the issue and working towards a solution.


Other related posts: