[THIN] Access management console hang on discovery

  • From: Angela <angela_smith9@xxxxxxxxxxx>
  • To: "thin@xxxxxxxxxxxxx" <thin@xxxxxxxxxxxxx>
  • Date: Sat, 11 Jul 2015 09:15:21 +1000

Hi

I'm still struggling with this issue. The only obvious thing I can see is that
the Access Management console fails to discover on 2 servers that have Office
2010 installed. AMC discovers on those servers with Office 2003 (both which I
need to demise). Could this be causing the issue? All other software versions
like .Net and C++ are identical..

Is it worth reinstalling the rollup pack or citrix itself?

Thanks
Ang

From: angela_smith9@xxxxxxxxxxx
To: thin@xxxxxxxxxxxxx
Subject: [THIN] Re: Access management console hang on discovery
Date: Thu, 2 Jul 2015 22:46:37 +1000




Hi

I tried to put the ZDC server into the AMC but it fails also. Doesn't even try
to connect. When I use local it hangs in a loop searching for farm but never
finds anything..

So today I decided to install the latest version of the AMC. Doing this
removed the configure option all together so I could only do a discover..
Doing a discover failed. It basically had no farm listed. I ended up
re-registering all components of AMC via:

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\regasm
/codebase "C:\Program Files\Common Files\Citrix\Presentation Server -
Administration Snap-in\PSE.Core.dll"

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\regasm
/codebase "C:\Program Files\Common Files\citrix\Access Management Console
- Diagnostics\CdfExtension.dll"

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\regasm
/codebase "C:\Program Files\Common Files\citrix\Access Management Console
- Dashboard Watcher\DWExtension.dll"

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\regasm
/codebase "C:\Program Files\Common Files\citrix\Access Management Console
- Knowledge Base\KnowledgeBaseExtension.dll"

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\regasm
/codebase "C:\Program Files\Common Files\citrix\Access Management Console
- Hotfix Management\HotfixExtension.dll"

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\regasm
/codebase "C:\Program Files\Common Files\citrix\Access Management Console
- Legacy Tools\MMCPlugIns\LegacyToolsExt\CMCLaunchExtension.dll"

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\regasm
/codebase "C:\Program Files\Common Files\citrix\Access Management Console
- Report Center\ReportCentreExtension.dll"

C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\regasm
/codebase "C:\Program Files\Common Files\citrix\License Server -
Administration Snap-in\LicensingExtension.dll"

This gave me the configure option back but it still fails to find my Citrix
farm. I'm thinking it may be an issue with the versions of .Net. I have .Net
2, 3.5 and 4 installed. I'm thinking about uninstalling the AMC and all .net
versions. If I go down this path can I simply install V4 or should I install
all 3 .Net versions again? Am I on the right path? Any other options?

Thanks
Ang


Date: Wed, 1 Jul 2015 10:48:10 -0400
Subject: [THIN] Re: Access management console hang on discovery
From: jasoncitrix@xxxxxxxxx
To: thin@xxxxxxxxxxxxx

I am not sure, we only use the Console off the one server that is the ZDC and
using the local. If you put the server that is the ZDC into the server list
when you run from other servers does it pick up?Also you might try adding
multiple servers so that if one fails it can try the next one
On Tue, Jun 30, 2015 at 7:18 PM, Angela <angela_smith9@xxxxxxxxxxx> wrote:



Hi Jason

Ive got the AMC using "Local". However I also tried to connect to the other
working servers but it still fails. Its almost like I'm missing something or
there is a config issue.. I didn't think there was much in relation to config
for the AMC.. The software looks identical to other working server (in
relation to versions)..

Thanks
Ang

Date: Tue, 30 Jun 2015 10:29:27 -0400
Subject: [THIN] Re: Access management console hang on discovery
From: jasoncitrix@xxxxxxxxx
To: thin@xxxxxxxxxxxxx

When you run the discovery are you pointing the discovery to the ZDC? or
launching the console from that server and clicking the "Add local"?
On Tue, Jun 30, 2015 at 10:11 AM, Angela <angela_smith9@xxxxxxxxxxx> wrote:



Hi again

More information.. I have 5 servers in my Windows 2003 XenApp 4.5 farm (rollup
7). I was tasked to demise 3 servers from my farm:

- 1x Zone Data Collector
- 2 x Citrix 4.5 servers
- I moved the ZDC role to another server
- I powered off the 2 Citrix servers (without removing from the farm) as I
wanted to ensure ZDC function worked on other server
-
I then realized that the Access Management console fails to launch on
the 2 Citrix servers. The consoles now load but hang on "Discovery in
Progress". Discovery never finishes and no errors are being logged in
event viewer.
- I powered the 2 Citrix Server back on to see if that
would allow the discovery to finish. It didn't, the AMC still fails on
the 2 servers that will remain. However the AMC console works on the 2
servers that I need to demise. Discovery goes through and works fine. However
I need to demise these 2 servers.
- I tried a recreatelhc but that made no difference
- Ive rebooted server but that made no difference

I
was looking to upgrade the AMC software but the versions are the same
on the working and non working servers. A Help\About says "Citrix
Access Management Console Version 3.0.0.0. The "Citrix Access
Management Console - Framework" is 4.5.2.0. I don't want to introduce
more changes in case it breaks something else.

Any help appreciated as I have spent so much time trying to resolve.. Does
anyone have any ideas?

Thanks
Ang




Other related posts: