[THIN] Re: APPV 5.0 (SCM and Publishing Server), PVS 7 and XA6.5

  • From: James Scanlon <scanjam@xxxxxxxxxxx>
  • To: Thin <thin@xxxxxxxxxxxxx>
  • Date: Wed, 7 May 2014 22:06:47 +1000

Hi Brandon,

Yes we definitely have those exclusions set (first article we came across!) - 
if we stop or uninstall the CUPM it doesnt make a difference either.

 

Only some apps are affected - not all. I thought it was the package, so started 
repacking them to no avail. (especalyl considering they launched first time)

 

The only solution was moving the package install source from %programdata% to 
d:\App-V and script a server start up to wipe / clear this directory on reboot.

 

Now all packages open everytime, all the time! :)

Cheers everyone for the assistance and pointers.

James 

 



From: brandon.mitchell@xxxxxxxxxx
To: thin@xxxxxxxxxxxxx
Subject: [THIN] Re: APPV 5.0 (SCM and Publishing Server), PVS 7 and XA6.5
Date: Mon, 28 Apr 2014 12:09:05 +0000







Are you using UPM?
 
https://support.citrix.com/proddocs/topic/user-profile-manager-5-x/upm-using-with-app-v.html
 
Profile management and App-V
 
Updated: 2014-04-08
 
You can use Profile management 5.x in the same environment as Microsoft 
Application Virtualization 5.0 (App-V 5.0).
 
You must exclude the following items using Profile management exclusions:
 
·         Profile Management\File system\Exclusion list\directories:
o   AppData\Roaming\Microsoft\AppV\Client\Catalog
o   AppData\Local\Microsoft\AppV
·         Profile Management\Registry\Exclusion list:
o   Software\Microsoft\AppV\Client\Integration
o   Software\Microsoft\AppV\Client\Publishing
 
If you don't exclude these items, App-V applications work the first time users 
access them but they fail, with an error, on subsequent logons. For 
instructions on setting exclusions, see To include and exclude items.
 
If the UserLogonRefresh setting is enabled in App-V, disable the Profile 
streaming policy in Profile management.
 
For an example of how to sequence an App-V application, see 
http://support.microsoft.com/kb/2830069.
 
 


From: thin-bounce@xxxxxxxxxxxxx [mailto:thin-bounce@xxxxxxxxxxxxx] On Behalf Of 
James Scanlon
Sent: Tuesday, April 22, 2014 7:59 AM
To: Thin
Subject: [THIN] Re: APPV 5.0 (SCM and Publishing Server), PVS 7 and XA6.5
 

Tim , Gareth, Joe - Thanks all for your replies, very much appreciated!

Ill have a look through and see what I can get working! :)
Regards

James




From: garethandhollie@xxxxxxxxx
To: thin@xxxxxxxxxxxxx
Subject: [THIN] Re: APPV 5.0 (SCM and Publishing Server), PVS 7 and XA6.5
Date: Tue, 22 Apr 2014 15:09:28 +1200

Hi,
 
Also you should look at the PVS Cache Mode. We had a lot of issues with Office 
2013 launching and then not and found if you switched it from “Cache on Device 
Hard Drive” to “Cache in Device RAM with Overflow to Disk” programs seem to 
launch more consistently.
 
Gareth
 
From: thin-bounce@xxxxxxxxxxxxx [mailto:thin-bounce@xxxxxxxxxxxxx] On Behalf Of 
Joe Shonk
Sent: Tuesday, 22 April 2014 7:47 a.m.
To: thin@xxxxxxxxxxxxx
Subject: [THIN] Re: APPV 5.0 (SCM and Publishing Server), PVS 7 and XA6.5
 

Hello,

 

You should clear the App-V cache at the same time you reseal your PVS image.  
Hence, it shouldn't be part of the image.

 

Joe

 

On Mon, Apr 21, 2014 at 11:04 AM, James Scanlon <scanjam@xxxxxxxxxxx> wrote:


Please anyone if you have advice or suggestions id love to hear them... still 
having quite a few issues this way and it seems most people are baking the 
app-v apps into the image? I simply want PVS image with app-v streaming / 'full 
infrastructure mode'..... :)

I saw something about moving the package root outside of the image to the pvs 
static / cache disk? is that a good idea?


Cheers

scanjam


 





From: scanjam@xxxxxxxxxxx
To: thin@xxxxxxxxxxxxx
Subject: APPV 5.0 (SCM and Publishing Server), PVS 7 and XA6.5
Date: Wed, 16 Apr 2014 20:01:04 +1000


 



As the title suggests we are running AppV 5.0 SP2 with a recently installed 
http://support.microsoft.com/kb/2934349

 

I have a XenApp 6.5 PVS image in read only mode and when launching AppV apps I 
seem to be able to launch some apps first time only.

Doesnt matter if im admin, or normal user

Doesnt matter if im using RDP or ICA

Doesnt matter if I clear my profile - from then on the apps are dead, for all 
users.

Fix so far is reboot... which is AWESOME!

 


We are using the Appv 5 publishing server with Shared content mode (support 
staff etc need to be able to deploy apps to servers, and dont want packages 
baked into the image if at all possible)

 

Example:

If I log on, launch an AppV app Winzip 18, It loads first time, then on 
subsequent retries does literally nothing

From then on the launching of other AppV apps break SQL Management console

Yet one AppV application, AGS Remote Desktop, continues to work without issue - 
launches everytime!

The logging of AppV 5 client is garbage, and there is literally nothing in the 
event logs either, all we see is the operation event log info of:

A request for the file 
C:\ProgramData\App-V\12160C7F-CB16-4D45-BE71-A36E3BBD15A2\37568102-90C5-4115-8382-28A009AF1C5F\Root\en-US\winzip64.exe.mui
 from process 0x2144 is being processed as an alternate user 
S-1-5-21-162393699-21082718-2283726478-38935.

 

We do little in preparing the PVS image before read only mode other than 
removing all the packages from the server before shutdown

Get-AppvClientPackage -All | Remove-AppVClientPackage

 

My Questions:

Has anyone seen this behaviour?

Are there further steps to prepare the PVS image for running AppV Apps in 
infrastructure mode? i.e (an AppV refresh script at the server startup?)

 

Thank you in advance,

Beers on me if you can get this working for us!! :)

James
 



This e-mail message, including any attachments, is for the sole use of the 
intended recipient(s) and may contain information that is confidential and 
protected by law from unauthorized disclosure. Any unauthorized review, use, 
disclosure or distribution is prohibited. If you are not the intended 
recipient, please contact the sender by reply e-mail and destroy all copies of 
the original message.
                                          

Other related posts: