[slack-ru] Re: stardict 2.4.3

  • From: alex <alexander@xxxxxxxxxxxx>
  • To: slack-ru@xxxxxxxxxxxxx
  • Date: Tue, 28 Sep 2004 11:29:37 +0300

Mikhail Pachkov wrote:

Собирал ли кто сабж? Под каррент вылетает с ошибкой:

In file included from stardict.h:27,
from stardict.cpp:35:
prefsdlg.h:43: error: `GtkOptionMenu' was not declared in this scope
prefsdlg.h:43: error: `option_menu' was not declared in this scope
prefsdlg.h:43: error: parse error before `*' token
stardict.cpp: In static member function `static gboolean AppCore::on_window_state_event(GtkWidget*, GdkEventWindowState*, AppCore*)':
stardict.cpp:255: error: `GTK_COMBO' undeclared (first use this function)
...


Гтк2 стоит.

Приветствуются любые идеи!

Удачи!

Михаил



Цитирую:

=====================================================================
В сообщении от 22 Июль 2004 15:19 Пашев Игорь Николаевич написал(a):

надо убрать опции GTK_DISABLE_DEPRECATED и GDK_DISABLE_DEPRECATED.
Кроме того, в pixmaps/Makefile.am написано:
SOURCES =<tab> <tab>\
        stardict.png
EXTRA_DIST = \
        $(appicon_DATA)
Что влечёт непонятную ошибку

А вот так нормально:
SOURCES = stardict.png
EXTRA_DIST = $(appicon_DATA)


Вдогонку: после всего: autoreconf, configure etc...
-- Никогда не было, чтобы чего-нибудь не было, всегда было, чтобы что-нибудь было. ===============================================




Other related posts: