[slack-ru] Re: iproute2 не компилится в slack 9.1

  • From: Романенко Денис <ash@xxxxxxxxxx>
  • To: <slack-ru@xxxxxxxxxxxxx>
  • Date: Wed, 17 Mar 2004 13:15:46 +0200

Попробуй в /usr/include посмотреть символьные ссылки. Они должны на текущее
ядро ссылаться. там /usr/include/linux и /usr/include/asm
и еще чего-то
  -----Original Message-----
  From: slack-ru-bounce@xxxxxxxxxxxxx
[mailto:slack-ru-bounce@xxxxxxxxxxxxx]On Behalf Of Игорь
  Sent: Wednesday, March 17, 2004 12:45 PM
  To: slack-ru@xxxxxxxxxxxxx
  Subject: [slack-ru] iproute2 не компилится в slack 9.1


  Не могу скомпилить пакет iproute2, iproute2-2.4.7-now-ss020116-try.tar.gz
, в slack 7.1 все нормально компилится. В 9.1 (ядро 2.4.22)выдает ошибку:
  make[1]: Entering directory `/usr/src/iproute2/lib'


gcc -D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -g -I../include-glibc -I/usr
/include/db3 -include
../include-glibc/glibc-bugs.h -I/usr/src/linux/include -I../include    -c -o
ll_map.o ll_map.c
  In file included from ../include-glibc/netinet/in.h:7,
                   from ll_map.c:19:
  /usr/src/linux/include/linux/in.h:140: field `gr_group' has incomplete
type
  /usr/src/linux/include/linux/in.h:141: confused by earlier errors, bailing
out
  make[1]: *** [ll_map.o] Error 1
  make[1]: Leaving directory `/usr/src/iproute2/lib'
  make: *** [all] Error 2

  что можно предпринять ?

Other related posts: