[rmaexpress_help] Re: RMAExpress still crashes after 1.0 beta 8

  • From: Ben Bolstad <bmb@xxxxxxxxxxxxx>
  • To: rmaexpress_help@xxxxxxxxxxxxx
  • Date: Mon, 03 Mar 2008 07:50:11 -0800

I am assuming that if you have installed from source on Ubuntu then you
probably have the gnu gcc tool chain on your system. you should be able
to invoke RMAExpress using gdb via something like

gdb ./RMAExpress

then you might need to type R at the gdb prompt to get it to run. When
it crashes typing backtrace at the gdb prompt would give me details on
where it segfaulted.

Ben



On Mon, 2008-03-03 at 07:42 -0800, Alex Feltus wrote:
> Ben:
> 
> Thanks.  I have lowered the number of arrays that I am
> inputting.  Even as low as 460 arrays, I get a
> segmentation fault at the Background Adjustment stage.
>  Data loads OK.  Data Structures load OK.
> 
> This is a different array platform than U133 Plus 2.0.
>  It is GEO Accession GPL192.
> 
> I would like to monitor with a debugger.  How can I do
> this if I don't have a C/C++ debugger?
> 
> Thanks,
> Alex
> --- Ben Bolstad <bmb@xxxxxxxxxxxxx> wrote:
> 
> > I have run it up to 2500 HGU-133 Plus 2.0 arrays in
> > recent testing
> > without it exploding at my end. The cause of the
> > crash that was fixed in
> > 1.0 beta 8 was that i was using a 32 bit integer to
> > index data
> > (basically the previous situation was causing an
> > overflow condition),
> > this has been changed to indexing data via
> > row/column style coordinates.
> > Making the fix allowed me to go right up to 2500
> > with out problem (I
> > don't have to many more CEL files of this type lying
> > around right now,
> > though I suppose I could look for more on GEO).
> > 
> > If you could give me the backtrace from a debugger
> > it would be somewhat
> > useful for narrowing down the problem. If I
> > understand you correctly it
> > is seg-faulting somewhere between reading the data
> > and doing anything
> > else?
> > 
> > Best,
> > 
> > Ben
> > 
> > 
> > 
> > On Sun, 2008-03-02 at 20:51 -0800, Alex Feltus
> > wrote:
> > > Hey:
> > > 
> > > I have been able to normalize hundreds of arrays
> > with
> > > RMAExpress 1.0 beta 8 compiled from source on an
> > > Ubuntu 7.10 system with 8 Xeon cores and 16GB RAM.
> > > 
> > > However, I am unable to normalize a set of 2887
> > > arrays.  They appear to load but then I get a
> > > segmentation fault.  Your beta 8 bug fix (- Fix a
> > > potential crash situation in extremely large
> > datasets
> > > (eg would crash at approximately 1578 HGU-133 plus
> > 2.0
> > > CEL files)) sounds like my problem, but maybe the
> > > extra arrays kill it?
> > > 
> > > Thanks,
> > > Alex
> > > 
> 
> 
> 
>       
> ____________________________________________________________________________________
> Looking for last minute shopping deals?  
> Find them fast with Yahoo! Search.  
> http://tools.search.yahoo.com/newsearch/category.php?category=shopping
> 


Other related posts: