RAC Re: Load balancing

  • From: Anand Rao <panandrao@xxxxxxxxx>
  • To: racdba@xxxxxxxxxxxxx
  • Date: Sat, 10 Dec 2005 08:12:04 +0530

Hi David,

It certainly seems to be true from the documentation point of view!

i haven't tried it myself and i just can't find a RAC database to test
it...though most of documents you can see would suggest load_balance=on.

i guess your setup may not be working due to the 'services' parameter in
init.ora/spfile. Just check it once again, make it consistent for all
instances. you don't need to user alter system commands to add services.
ensure that local_listener parameter is also present for each RAC instance
and it is resolvable in tnsnames.ora.

Have you got entries for the individual RAC instances in tnsnames.ora? well,
i guess you might have read Metalink notes for configuring this....

lsnrctl services <listener_name> should give you the details of the
connection(s) per instance.

cheers
anand



On 09/12/05, David Sharples <davidsharples@xxxxxxxxx> wrote:
>
> Thanks, but in the docs here
> http://download-west.oracle.com/docs/cd/B10501_01/rac.920/a96597/psscadtl.htm#16638
>
> it says load_balance can be set to on, yes or true - is that incorrect?
>
>
> On 12/9/05, Anand Rao <panandrao@xxxxxxxxx> wrote:
> >
> > You need use load_balancing=ON :-)
> >
> > ensure that the tnsnames.ora is exactly the same on client and server
> > side.
> >
> > set the init.ora/spfile parameter service_names correctly on all
> > instances.
> >
>

Other related posts: