[pythran] pythran-0.7.1 Errors

  • From: "Crooks, Cynthia J" <cynthia.crooks@xxxxxx>
  • To: "pythran@xxxxxxxxxxxxx" <pythran@xxxxxxxxxxxxx>
  • Date: Wed, 22 Jul 2015 20:54:21 +0000

I am trying to compile and configure pythran-0.7.1 for one of our developers.
I am using python-2.7.10 which was built with the gcc-4.9.2 compilers. I am
building on a SLES 11 SP 2 machine. When I try to run "pythran dprod.py"
which the example dprod.py script, I am getting the following errors:

1. WARNING: Disabling color, you really want to install colorlog.

Colorlog is installed so I am not sure why I am getting this warning.


2.

In file included from
/hpc/apps/SLES/3.0/x86_64/gcc/4.9.2/include/c++/4.9.2/cassert:43:0,
from
/hpc/apps/SLES/3.0/x86_64/PYTHON/2.7.10/lib/python2.7/site-packages/pythran/pythonic/types/slice.hpp:10,
from
/hpc/apps/SLES/3.0/x86_64/PYTHON/2.7.10/lib/python2.7/site-packages/pythran/pythonic/include/types/list.hpp:10,
from
/hpc/apps/SLES/3.0/x86_64/PYTHON/2.7.10/lib/python2.7/site-packages/pythran/pythonic/types/list.hpp:4,
from /tmp/tmpRfYrkB.cpp:8:

/hpc/apps/SLES/3.0/x86_64/PYTHON/2.7.10/lib/python2.7/site-packages/pythran/pythonic/types/slice.hpp:
In member function 'long int pythonic::types::slice::size() const':

/hpc/apps/SLES/3.0/x86_64/PYTHON/2.7.10/lib/python2.7/site-packages/pythran/pythonic/types/slice.hpp:172:28:
error: 'bitofsign' is not a member of 'nt2'
assert(nt2::bitofsign(step) != nt2::bitofsign(lower));
^

/hpc/apps/SLES/3.0/x86_64/PYTHON/2.7.10/lib/python2.7/site-packages/pythran/pythonic/types/slice.hpp:172:52:
error: 'bitofsign' is not a member of 'nt2'
assert(nt2::bitofsign(step) != nt2::bitofsign(lower));
^

/hpc/apps/SLES/3.0/x86_64/PYTHON/2.7.10/lib/python2.7/site-packages/pythran/pythonic/types/slice.hpp:175:28:
error: 'bitofsign' is not a member of 'nt2'

I am not sure how to proceed with debugging this. Any help would be
appreciated.

I do have logs of the build and install steps, if those would be of help.

Thanks for your help.

Cindy

Other related posts: