[pythran] Re: Pythran 0.7.4 is out!

  • From: Leopold Haimberger <leopold.haimberger@xxxxxxxxxxxx>
  • To: pythran@xxxxxxxxxxxxx
  • Date: Sat, 9 Jan 2016 17:28:35 +0100

Hi Serge,

yes, this has fixed it. Thanks a lot

Leo

Am 08.01.2016 um 20:18 schrieb serge guelton:

On Fri, Jan 08, 2016 at 04:21:08PM +0100, Leopold Haimberger wrote:
Dear Serge,

I have installed pythran 0.74 using conda, however I get the following
error:

pythran x.py
/home/opt/anaconda/bin/../libexec/gcc/x86_64-unknown-linux-gnu/4.9.1/cc1plus:
/lib64/libc.so.6: version `GLIBC_2.14' not found (required by
/home/opt/anaconda/libexec/gcc/x86_64-unknown-linux-gnu/4.9.1/../../../../lib/libgmp.so.10)
/home/opt/anaconda/bin/../libexec/gcc/x86_64-unknown-linux-gnu/4.9.1/cc1plus:
/lib64/libc.so.6: version `GLIBC_2.14' not found (required by
/home/opt/anaconda/libexec/gcc/x86_64-unknown-linux-gnu/4.9.1/../../../../lib/libgmp.so.10)
CRITICAL Cover me Jack. Jack? Jaaaaack!!!!
E: ('error: Command "/opt/anaconda/bin/g++-4.9 -fno-strict-aliasing -g -O2
-DNDEBUG -g -fwrapv -O3 -Wall -fPIC -DUSE_GMP -DENABLE_PYTHON_MODULE
-I/opt/anaconda/include -I/opt/anaconda/lib/python2.7/site-packages/pythran
-I/opt/anaconda/lib/python2.7/site-packages/numpy/core/include
-I/opt/anaconda/include/python2.7 -c /tmp/tmpRx_VQG.cpp -o
/tmp/tmpKS_cYv/tmp/tmpRx_VQG.o -std=c++11 -fno-math-errno -w" failed with
exit status 1',)

I am using CentOS 6.7. You will make many CentOS 6.x users out there happy
if you add packages that are compatible with GLIBC_2.12.
Of course I could try to build libgmp on my machine but before I do that I
though I let you know.

Kind regards,

Leo Haimberger
Hi Leo,

I just uploaded a new version of gmp built with a debian squeeze, no
more GLIB symbol greater that 2.2, that should be ok for you, please
tell me!


--
Ao. Prof. Dr. Leopold Haimberger
Department of Meteorology and Geophysics
Althanstrasse 14 1090 Wien
AUSTRIA
Tel. +43 1 4277 53712
Mobile: +43 664 260 5378
Fax +43 1 4277 9537
www: http://imgw.univie.ac.at/


Other related posts: