[pythran] Install bug

  • From: Pierre Augier <pierre.augier@xxxxxxxxxxxx>
  • To: pythran@xxxxxxxxxxxxx
  • Date: Thu, 30 Apr 2015 17:10:16 +0200

Hello,

I've just tried to build install the version from pypi and I get:

augier@nrj1sv224:/tmp/pythran-0.7.0$ python setup.py install
running install
running build
creating build
creating build/lib
creating build/lib/pythran
Traceback (most recent call last):
File "setup.py", line 281, in <module>
'bench': BenchmarkCommand}
File "/home/users/augier/opt/python/2.7.9..dist.wheezy/lib/python2.7/distutils/core.py", line 151, in setup
dist.run_commands()
File "/home/users/augier/opt/python/2.7.9..dist.wheezy/lib/python2.7/distutils/dist.py", line 953, in run_commands
self.run_command(cmd)
File "/home/users/augier3pi/opt/python/2.7.9..dist.wheezy/lib/python2.7/distutils/dist.py", line 972, in run_command
cmd_obj.run()
File "/home/users/augier/opt/python/2.7.9..dist.wheezy/lib/python2.7/distutils/command/install.py", line 563, in run
self.run_command('build')
File "/home/users/augier3pi/opt/python/2.7.9..dist.wheezy/lib/python2.7/distutils/cmd.py", line 326, in run_command
self.distribution.run_command(command)
File "/home/users/augier/opt/python/2.7.9..dist.wheezy/lib/python2.7/distutils/dist.py", line 972, in run_command
cmd_obj.run()
File "setup.py", line 93, in run
self.build_ply()
File "setup.py", line 41, in build_ply
assert os.path.exists(target)
AssertionError

Any idea ?

- debian wheezy with
libboost-python-dev libgoogle-perftools-dev libgmp-dev libboost-dev installed
- gcc (GCC) 4.9.2
- networkx and ply installed

Pierre

--
Pierre Augier - CR2 CNRS http://www.legi.grenoble-inp.fr
LEGI (UMR 5519) Laboratoire des Ecoulements Geophysiques et Industriels
BP53, 38041 Grenoble Cedex, France tel:+33.4.56.52.86.16


Other related posts: